Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'am using Windows-7 Home Basic 64 Bit OS. My system has stopped coming out of sleep mode. i.e. if I manually do sleep from shutdown menu, or close the lid, or sleep due to power plan, after re-opening the system, screen doesn't show anything. It remains blank. But everything works the way it should. i.e Hard-Disk, OS keeps running and I can shutdown also by pressing alt+F4 and Enter (in the blank).

I updated display drivers, Graphic drivers, Chipset drivers to the latest version. What could it be? (corrupt hibernate file?)

share|improve this question

3 Answers 3

up vote 3 down vote accepted

The c:\hiberfile.sys file is not used for sleep mode, only hibernation. So corruption of that file is definitely not the issue here.

This is almost certainly a driver issue. It looks like your graphics card is not correctly handling going from S3 back to S0 (sleep back to fully powered on).

1) Try updating your graphics card driver

2) Try rolling back your graphics card driver to a previous known good version

enter image description here

3) Failing that driver rollback, try using System Restore to go back to a system state prior to the manifestation of your problem.

share|improve this answer
    
wow. perfect. thanks a lot –  Manish Mishra Jun 1 '13 at 20:18
    
You're welcome! –  Austin ''Danger'' Powers Jun 1 '13 at 20:20

I had the same problem and I finally solved it - the cause of this problem is going to amaze you! :)

I checked the drivers of both my video card and the built-in graphics card, they both seemed to be updated. then out of no reason at all I decided to go check the power saving settings (sleeping mode, screen poweroff etc..) and the thing I found was that screen poweroff was set to 15 minutes, but computer sleep mode as not set! (i.e was set to 'never') i changed that to 15 minutes, to match the screen poweroff timer, and never had this problem again.

I guess that screen poweroff and computer sleep mode go together - if the PC is'nt sleeping, it does not expect a waking command, therefore will not turn on the screen.

I also tried to set them both to never, and left it a night. As expected, the PC remained as I left it. Its a bit power consuming solution, but is also a good one.

share|improve this answer

Executing powercfg -h off from an elevated command prompt seems to be working for me, and removed the hiberfil.sys file, which I could not otherwise remove, saving precious SSD space.

I'm using an ATI/AMD Radeon HD 7790, and depending on driver version I was getting a wide range of sleep/wake problems. Currently I'm using 13.11 Beta 7, as it seems to have the best PowerCore implementation: saves me 10-20 watts at idle.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.