Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have followed this tutorial: http://www.madboa.com/geek/dhcp-failover/

However, I can not seem to get a lease at my windows client.

I have set both servers (CentOS 6.2) in virtual machines, connected by the same lan segment. (with VMWare Workstation). My windows Client is also a virtual machine in the same network segment. If I, as in the tutorial, made a single DHCP server, I was able to get a lease. But now that I have 2 dhcp servers, connected with the failover protocol, I can't seem to get the lease.

I have no idea where the problem could be. I have already synced both servers with the ntpdate command, giving them the same time and date (so there is no time difference).

The log from the secondary server gives me 'peer holds all free leases' and the log from the master gives me 'not responding (recovering)'

I can ping from master to slave and slave to master, but I can not ping from the windows client to either the master or the slave. If I do so, I get this:

PING: transmit failed, error 1231.

PING: transmit failed, error 1231.

Please tell me whatever other relevant info I should give.

share|improve this question
    
Try: disable firewall on both (sudo /etc/init.d/iptables stop), disable SELinux (sudo setenforce 0) and restart DHCPd on both. Also, it would be useful to check less /var/log/messages –  Chris Jun 2 '13 at 16:05
    
Didn't do the trick, I still can't get a lease. The less /var/log/messages give me basicly the same as the regular log, saying 'not responding (recovering)' and the secondary 'peer holds all free leases' –  user228507 Jun 2 '13 at 16:45
    
Actually, I think it did work,, I was reading some more documentation, came back to my virtual machine and there was a different log, which enabled me to debug and get it working, thanks @Chris ! –  user228507 Jun 2 '13 at 17:16
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.