Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

FINAL UPDATE: Here is the best solution that I found after going through this problem lots of times. The question below is outdated because as it turns out the computer is not the problem; the monitor is the problem.

Ubuntu doesn't offer 1280x1024 but that's what my monitor has
--> I want to set that resolution but need help doing so.

Ubuntu offers 1360x768, 1152x864, 1024x768 when using the Nvidia driver version 180. This is Ubuntu 9.04 installed as "Wubi" through Windows, I believe it's the amd64 version.

Google gave me this precise explanation which is complete latin to me; I'm a Windows guy and not familiar with Terminal. These SU questions also don't provide answers, hence this new question. I hope you can help, and I will provide additional info if required.

share|improve this question
add comment

2 Answers

up vote 1 down vote accepted

Here is why detecting monitor matters: In Ubuntu, the default set in /etc/X11/xorg.conf for the supported refresh rates of the monitor are extremely conservative. This is because some CRT monitors could stop working if you set refresh rates too high.

The solution with an undetected monitor is usually this:
1- Find somewhere the actual supported refresh rates for your monitor
(for example you can find from that page: http://www0.shopping.com/xPF-BenQ-BenQ-19-LCD-T905-TCO99-Monitor-Silver-Black-12ms that the vertical range is 56-76 and the horizontal range is 31-81).
2- Edit the /etc/X11/xorg.conf file in section "Monitor" to use those ranges:
 Section "Monitor"
   Identifier "Monitor0"
   VendorName "Unknown"
   ModelName "CRT-0"
   HorizSync 31.0 - 81.0
   VertRefresh 56.0 - 76.0
  EndSection

3- Restart X or your computer
4- Run nvidia-settings and the resolution you're looking for should be there.

share|improve this answer
    
Yay, this provided the desired resolution! Oddly, the refresh rate is 50 Hz and 52 Hz is also available, but neither 60 Hz nor higher is available. It works fine, though! –  Torben Gundtofte-Bruun Nov 1 '09 at 9:30
    
Restart X with the command sudo /etc/init.d/gdm restart. –  Torben Gundtofte-Bruun Feb 26 '10 at 11:50
add comment

Run nvidia-settings and check the tab that's labeled "X Server Display Configuration". Is the driver correctly detecting your monitor? If not, are you able to select the correct resolution on that screen?

share|improve this answer
    
The monitor model is "CRT-0", not "Benq T905" - so I'd say no my monitor is not recognized. This is where the above mentioned resolutions are listed, but not the one I need. How can I get it to detect my specific monitor? I expect that would then allow me to select the correct resolution? –  Torben Gundtofte-Bruun Oct 25 '09 at 11:37
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.