Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

How can I disable copying files via drag-and-drop in Windows Explorer in Windows 7?

Note that I don't want to disable drag-and-drop completely nor in the start menu, just disable copying (duplicating) files when users drag-and-drop.

share|improve this question
    
In a GUI OS, drag-and-drop is at the heart of the process. If you wish to move the files rather than copy, that is another matter but you cannot simply tell the system to not copy files unless you prevent doing so with file permissions. If it is an accessibility issue there are tools. What are you trying to accomplish in preventing files from being copied? –  edwardbackstrom Jun 3 '13 at 3:25
    
About half my PC clients have 'copy of ...' files and I've seen as much as a full GB of duplicate files. –  John Jun 3 '13 at 3:55
1  
Just search for and delete "Copy of..." files. Script it out and run it regularly. ;) –  Ƭᴇcʜιᴇ007 Jun 3 '13 at 4:00
2  
That's funny, I thought the real problem was MOVE drag and drop, you know moving network folders accidentally and getting complaints about "disappeared folders". COPY happens when moving things from a drive to another, otherwise the default is MOVE. So why would your users drag things between drives? It doesn't sound like accidental misclicks. If users are trying to move things between various network shares, why not consider combining them into one large (virtual) drive? Etc. Perhaps there's some root cause factor here. –  mtone Jun 3 '13 at 5:58

2 Answers 2

up vote 3 down vote accepted

Windows doesn't provide a built-in way to change the default action of drag and drop, but I found a tool called Drag'n'Drop Editor which will let you change the default action to "move".

This doesn't disable copying (you can still hold Ctrl to make a copy), but it should help prevent accidental copies.

share|improve this answer

Perform the following steps :

  1. RIGHT click on start button
  2. select Properties
  3. in "Taskbar and start menu properies" select the "Start Menu" Tab
  4. Select "Customize" (doesnt matter if you are using the classic or general style)
  5. Click on advance and scroll to search "Enable Drag and drop"
  6. Uncheck it
  7. Click Apply.

This should do the trick.

share|improve this answer
2  
although this does prevent files from being "copied" to the start menu, it does not answer the OP's apparent question of preventing files being copied via Explorer. –  edwardbackstrom Jun 3 '13 at 3:48

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.