Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a DLink DIR-605L, which is a 10/100 Mbps (non-ADSL) router. I am connected to it on a Desktop with a Realtek Network Adapter onboard MSI P45 Platinum. I also have an Asus X54H-SX137D. Both these are able to connect fine to my router.

About 100 feet away, in a different building (next to my house) there's another desktop with an Intel NIC onboard a DG33FB. It is connected by a long Ethernet Cat-5 cable, which my router is refusing to detect.

Note that

  • WAN on the router works. Every Ethernet port on the router works, tested with my Realtek NIC.
  • The Intel NIC is able to connect to my Realtek NIC as well as my Asus laptop at 1.0 Gbps full duplex. So obviously all pairs of the cable are crimped firmly.
  • BUT the Intel NIC at the other end of the cable is not recognized by the router. As if it wasn't there at all.
  • I crimped both T-568A and T-568B orders of crimping, both times link with the NICs was perfect, but link with the router was nonexistent.

How can this happen? Even if Auto-MDI/MDIX isn't enabled on all ports of the router, which I highly doubt, I tried it both ways. Any ideas?

share|improve this question
    
It's unclear if you're using T-568A on one end, and T-568B on the other end, which makes a cross-over cable, or if you've tried 568A on both sides, as well as 568B on both sides (for straight-thru); If you can connect host to host over that cable, then it seems its wired cross-over. This might not work for connecting to a switch. (Auto crossover detection works more reliably for short jumpers). If you haven't already, could you try with both sides crimped to either the A std or the B std for a straight-thru cable? –  Nevin Williams Jun 5 '13 at 23:19

1 Answer 1

up vote 1 down vote accepted

The problem was something else entirely.

While experimenting with the other Intel NIC, I had set Speed to 1.0 Gbps instead of Autonegotiation. This resulted in it not being able to connect to the router which is 10/100.

It appears that my router does actually support crossover-detection.

Thanks.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.