Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

i try to add ssh private key auth to my NAS. It is a NAS from WD My Book World.

My problem is when i try to connect with a key it still ask a password.

here is my .ssh folder : .ssh/ authorized_keys keybkup keybkup.pub known_hosts

/etc/ssh_config

# Host *
#   ForwardAgent no
#   ForwardX11 no
#   RhostsRSAAuthentication no
    RSAAuthentication yes
#   PasswordAuthentication yes
#   HostbasedAuthentication no
#   BatchMode no
#   CheckHostIP yes
#   AddressFamily any
#   ConnectTimeout 0
#   StrictHostKeyChecking ask
    IdentityFile /root/.ssh/identity
#   IdentityFile ~/.ssh/id_rsa
#   IdentityFile ~/.ssh/id_dsa
#   Port 22
#   Protocol 2,1
#   Cipher 3des
#   Ciphers aes128-cbc,3des-cbc,blowfish-cbc,cast128-cbc,arcfour,aes192-cbc,aes256-cbc
#   EscapeChar ~

and the /etc/sshd_config (part of it)

Port 22
Protocol 2,1
#ListenAddress 0.0.0.0
#ListenAddress ::

# HostKey for protocol version 1
#HostKey /etc/ssh_host_key
# HostKeys for protocol version 2
#HostKey /etc/ssh_host_rsa_key
HostKey /etc/ssh_host_dsa_key

# Lifetime and size of ephemeral version 1 server key
#KeyRegenerationInterval 1h
#ServerKeyBits 768

# Logging
#obsoletes QuietMode and FascistLogging
#SyslogFacility AUTH
#LogLevel INFO

# Authentication:

#LoginGraceTime 2m
#PermitRootLogin yes
#StrictModes yes
#MaxAuthTries 6

RSAAuthentication yes
PubkeyAuthentication yes
AuthorizedKeysFile      .ssh/authorized_keys
share

migration rejected from serverfault.com Jun 4 '13 at 3:34

This question came from our site for system and network administrators. Votes, comments, and answers are locked due to the question being closed here, but it may be eligible for editing and reopening on the site where it originated.

closed as too localized by Sathya Jun 4 '13 at 3:34

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

1  
Your local system should have a log, what does it say in there while connecting? –  NickW Jun 3 '13 at 9:40
    
auth.info sshd[6121]: rexec line 79: Unsupported option UsePAM –  Paul E. Mogilöv Jun 3 '13 at 10:32
    
srry wrong line ... auth.info sshd[4156]: Disabling protocol version 1. Could not load host key –  Paul E. Mogilöv Jun 3 '13 at 10:41
    
Sounds like you may have permissions issues with your local id_rsa, make sure it is owned by your user, and chmod it 600. –  NickW Jun 3 '13 at 10:56
    
you mean for sure .ssh/ authorized_keys ? They hare 600 already :( –  Paul E. Mogilöv Jun 3 '13 at 11:27

Browse other questions tagged or ask your own question.