Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I enabled filecache by (require 'filecache) in my init.el. it is convenient until i was trying to make a new file buffer that uses similar file name.

Say, i once edited a file "../path1/foo.txt", now i want to create a new file "../path2/foo.txt", emacs won't allow me to do that, it insists that i want to open "../path1/foo.txt". No matter that i manually pressed C-x C-f and input the full path for the new file, Emacs just automatically jumps to the existing file in minibuffer, and i just could not make my new file.

do i have to disable filecache in such case? thanks

share|improve this question
    
Did you add any other configuration for filecache in your init.el? Normally, filecache only operates if you hit C-TAB to expand from the file cache, and if you are just typing and hit return, it is not invoked. –  Alan Shutko Jun 3 '13 at 16:50
    
not really, that is the other thing i dont understand, i use emacs24.3 in win7, i also enabled ido mode as: '(ido-enable-flex-matching t) '(ido-enable-last-directory-history t) '(ido-everywhere t) '(ido-mode (quote both) nil (ido)) is that causing the problem of autocomplete behavior? –  shelper Jun 3 '13 at 17:06

1 Answer 1

up vote 1 down vote accepted

Yes, ido is the cause here.

It looks like ido-find-file won't let you create new files. It does allow you to escape back into normal find-file by hitting C-f. That should let you create the files.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.