Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am new to ffmpeg, just trying to build an SDP file for streaming. I'm facing an error when I run the command

ffmpeg -re -i "sample.mp4" -f rtp rtp://127.0.0.1:10000 -flags +global_header -c:a libvo_aacenc -vn -map 0:1 -f rtp rtp://127.0.0.1:10002 > 10000.sdp

The error is:

Unknown encoder 'libvo_aacenc'

How do I resolve this?

share|improve this question

migrated from stackoverflow.com Jun 3 '13 at 19:34

This question came from our site for professional and enthusiast programmers.

    
You need to include the complete ffmpeg console output that shows up after you enter your ffmpeg command. –  LordNeckbeard Jun 3 '13 at 20:13

1 Answer 1

Your ffmpeg was probably not configured with --enable-libvo-aacenc. However there are other, higher quality AAC encoders that can be used with ffmpeg. ffmpeg -codecs will list all encoders that have been configured for each supported codec; look for the "aac" line and the encoders listed on that line. If you don't have any other AAC encoder you can always use the experimental AAC encoder that is built-in to ffmpeg (-strict experimental -c:a aac), or build your own ffmpeg with your favorite AAC encoder. For guidance on selecting an AAC encoder, see the ffmpeg AAC Encoding Guide.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.