Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've tried using VAC virtual audio cable, as well as virtual audio streaming. Unfortunately, none of these solutions provide a way to send audio output to a microphone input. None of the virtual audio cable related posts on here or internets address this specific limitation.

The reason I want to do this is to stream audio to the microphone and set the microphone as input device for another program. This "other program" only allows microphone inputs to be used as its input device.

See how no mic's are listed as output devices: http://imgur.com/a/VBjUy

There is a software called Solicall which actually allows this. But I would like to do this through VAC virtual audio cables because Solicall only allows one instance running. Thus, I can't do my audio routing method more than once simultaneously. I have yet to find a better solution however than Solicall.

Someone please post if you found a way to do this with virtual audio cables, or any solution more elegant than Solicall. Currently, all the virtual audio cable programs I've tried do not allow microphones (real or virtual) to be selected as output.

share|improve this question

Maybe you should give a try at Jack. It allows all types of virtual cabling. Jack is better on GNU/Linux and Mac OS X, but it seems it's possible to run it on Windows.

Maybe Pure Data can be interesting too.

share|improve this answer

I had this problem recently with Rosetta Stone. It only allowed you to choose inputs marked as a "Microphone".

Virtual Audio Cable supports marking cables as Microphones. You just have to select the cable you want to edit in the Virtual Audio Cable Control Panel (vcctlpan.exe) and then check the box that says "Mic" in the top right corner.

Make sure you run the control panel as administrator to make changes

If the program still does not recognize anything then I would try reinstalling the program itself and/or Virtual Audio Cable. Beyond that you will need to be more specific about the program for me to give you any more suggestions :)

share|improve this answer
    
Although this is an old question, you are welcome to answer. What would improve your answer is details. Answers should explain clearly while avoiding links to do the work. Linking to other information is OK, but your answer should included the basics of the article in case the link gets broken. – CharlieRB Jan 25 at 21:55
    
@CharlieRB Thank you, I am a n00b – c0deous Jan 26 at 23:43

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .