Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have two probably related problems with Windows' Compatibility mode.

Compatibility tab missing, but not on all programs

The title is rather self-explanatory, but let me show you: the Properties window's Compatibility tab is missing for some executables, but not others. See how this NES emulator has the tab, but a game launcher doesn't.

compatibility tab absent

Compatibility wizard giving an error

Since I didn't see the Compatibility tab, I thought I could try the wizard from the right-click option "Solve compatibility problems" (approximate translation). An error shows up here, however. The error appears no matter how I launch the wizard: from a file that has a compatibility tab, from one that doesn't, from the compatibility tab itself or from a Start screen search ("compatibility").

compatibility wizard error

Suspected causes

Before reinstalling Windows, recently, I broke my installation by running a massive search-and-replace of C:\Users for D:\Users because I wasn't succeeding in moving user profiles and program preferences properly. From that broken installation, I backed up my user profile folder, including AppData, and the ProgramData folder. For one, having transferred things from an installation with a broken registry might be problematic.

Here, I committed two errors:

  • After reinstalling Windows and properly moving user profiles to D:\, including Default and Public, (according to the instructions in this answer), I put my backed-up data in my new user profile folder. However, instead of selecting a few relevant AppData folders, such as Mozilla Firefox and Adobe, to keep my settings in some applications, I copied (and overwrote) the whole AppData folder, which includes some folders titled Microsoft, for example.

  • I realized the backed up ProgramData folder was pointless, so I wanted to delete it. But some OS things, despite not being tied to the NEW installation, were still locked and non-deletable. Here, instead of booting to Ubuntu and deleting the folder to have a fresh one, I got lazy and just copied over the contents of the new installation (C:\ProgramData) to the backed-up folder (D:\ProgramData), said "yes" for overwriting (obviously with some errors on the locked files) and changed the ProgramData path in the registry, according to the same instructions.

This means my current installation most likely has some ProgramData files from the old one.

Now, I have a double question:

1- What could be the cause(s) of my compatibility tab and wizard issues? Could the above be the cause(s)?

2- If it's my fault and the mistakes described above have caused the problem, is there a way to fix this without reinstalling? Windows installs itself within 5 to 10 minutes, which is great; however, reinstalling my programs and re-configuring everything the way I want it to be takes a whole day, and I would really like to avoid it if possible.


Additional info

  • Windows 8 Professional, 64 bits
  • A clean installation was performed 1-2 day(s) ago, so malicious software and similar problems are unlikely.
  • My system is in French. I have grossly translated, in red, on the screenshots, what I thought was relevant, but if you need an additional translation, please don't hesitate to ask in the comments.
share|improve this question
    
Windows installs itself within 5 to 10 minutes, which is great; however, reinstalling my programs and re-configuring everything the way I want it to be takes a whole day, and I would really like to avoid it if possible. Tell me about it; I hate it when people jump to reinstall without at least trying to fix it. They must not use their systems much; anyone who has for a while will have to reset 100’s, even 1,000’s of settings here and there! Back in uni in 1997, I would reinstall now and then out of boredom/for fun. Now, I avoid it like the plague. I’m still using my XP install from 2003! –  Synetech Jul 17 '13 at 0:49
    
Re: moving data folders (C:/UsersD:), I agree. I long ago butchered my good old XP install from 2003 to segregate as many things into separate volumes as possible, including user data folders. As you learned the hard way, you have to be extra careful when messing with stuff like that because even though Windows uses lots of variables, it still expects certain things to be in certain places and breaks when they are not (as do many third-party programs). In this case, you could consider using a hard-link: move Users to D:, make a hard-link to it on C:, and leave the registry alone. –  Synetech Jul 17 '13 at 1:00
1  
The title is rather self-explanatory, but let me show you: the Properties window's Compatibility tab is missing for some executables, but not others. See how this NES emulator has the tab, but a game launcher doesn't. Can you discern any sort of pattern? That is, can you find any difference between the ones that it shows up for and the ones it doesn’t or similarity between the items in the two groups? For example, Windows executables vs. third-party, 32-bit vs. 64-bit, signed vs. unsigned, etc.? What about shortcuts? –  Synetech Jul 17 '13 at 1:03
    
Also, what if instead of looking for the Compatibility tab in the Properties dialog of the executable file itself, try creating a shortcut to it, then check the Properties dialog of the shortcut. –  Synetech Jul 17 '13 at 1:04
    
@Synetech 1. Linking to C:\ has been done in the past and it has caused issues with File History, which is why I did it with the registry this time. 2. Uhm, I was going to say that there seemed to be a company size pattern ("big company", "official" installed programs don't have the tab, while more random, "homemade" stuff is more likely to have it) because Dragon Nest, Ragnarok 2 and Internet Explorer lacked the tab, but then I saw that iTunes, Skype, Adobe Illustrator and Firefox have the tab. So no, I can't really see a pattern. 3. Shortcuts yield the same result as their parent .exe. –  Ariane Jul 17 '13 at 2:30

1 Answer 1

Error code 80070005 appears to be related to insufficient file/registry permissions according to some googling. This makes sense, given your post.

I would suggest running Process Monitor (http://technet.microsoft.com/en-us/sysinternals/bb896645) to figure out which file/registry keys lack the required permissions. Figure PM1-5 in this post shows how to filter by "access denied" in Process Monitor: http://blogs.technet.com/b/chad/archive/2009/12/30/how-to-use-sysinternals-process-monitor-and-process-explorer-to-troubleshoot-sharepoint.aspx.

In the end, I would seriously consider reinstalling Windows. If you messed up file/registry permissions this bad, chances are you will keep on bumping into weird errors.

share|improve this answer
    
dl.dropboxusercontent.com/u/51617032/Logfile.PML I saved the results from that filter. There seem to be some relevant errors, but I have no idea of what to do with them. Can you help me out? –  Ariane Jul 17 '13 at 3:40
    
One way to go forward would be to compare the permissions of those couple of files and registry keys with a working Windows installation. Here is a quick overview of mine for comparison: disk.pnf: SYSTEM + Administrator: All but special. Users: Read and exec + Read. PnpLockdownFiles: SYSTEM + Administrators: Special. Session Manager: CREATOR OWNER: Special. SYSTEM + Administrators: Full + Read. Users: Read. Temp (+ sub-folders):: SYSTEM + Administrators + <your user>: All but special. –  Zero3 Jul 18 '13 at 12:56
    
After verifying permissions on that temp folder, I would suggest deleting the msdt subfolder. It would appear that this one in particular is missing important permissions. It also seems to be part of the things you copied over based on your original post. So just delete it and let msdt.exe (some Windows diagnostics process) re-create it. Perhaps a reboot will be required. –  Zero3 Jul 18 '13 at 12:59
    
Before deleting something and possibly causing trouble, I tried to launch msdt.exe. It doesn't work, precisely like what happens with the compatibility wizard. Same error code. Should I still try deleting the folder? Or should I try to reproduce your permissions first? Also, I may be missing something, but usually, when you delete the folder of a program, it stops working. Won't msdt.exe stop working once the msdt folder, its folder, has been deleted? –  Ariane Jul 18 '13 at 16:44
    
I would check the permissions first, especially on the temp folder (+ msdt subfolder). If you delete the msdt subfolder and the permissions on the temp folder are still wrong, chances are you 'll end up with the same problem as before. I would still delete the msdt subfolder, as folders inside a temp folders are of a temporary nature and thus normally safe to delete (you can always just move it somewhere else to have a backup in case it doesn't change anything). –  Zero3 Jul 19 '13 at 14:53

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.