Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to save a Word document as .docx, but each time I click the 'Save' button the dialog reappears and asks me where to save the file. This only happens when I try to save it as a .docx file, any other format works just fine. I have tried pasting the contents into a new file, but the same happens.

I really need the functionality from .docx though, since there are quite a few formulas in the file.

The version I use is Word 2010.

share|improve this question
    
Does your default template contain any macros? –  Adam Jun 4 '13 at 7:35
    
@Adam it does not. As far as I know it's the default template that is installed with Word. –  Simon Verbeke Jun 4 '13 at 11:00
1  
@SimonVerbeke - Sounds like you are trying to save a read-only file. –  Ramhound Jun 4 '13 at 11:52
    
I did some more troubleshooting, and it seems like Word is having issues trying to save a formula. –  Simon Verbeke Jun 4 '13 at 15:12
2  
Too late to edit my comment. I retyped all the formulas in a new document, and now it saves without issues. –  Simon Verbeke Jun 4 '13 at 15:26

12 Answers 12

up vote 3 down vote accepted

Answer from comments in OP:

I retyped all the formulas in a new document, and now it saves without issues.

share|improve this answer

It's a Word bug. It sometimes happens when working with formulas and affects versions 2007 and 2010, possible newer ones too.

To avoid re-typing formulas or saving in compatibility mode (which converts formulas to images):

  1. Install a clipboard manager (Ditto Portable is a good one).
  2. Switch to Word, press Ctrl+A to select everything and copy it.
  3. Use clipboard manager to export clipboard to a file. Clipboard should be preserved anyway, but do it just in case.
  4. Close all instances of Word. Copying everything to a new instance will work, but you need a full Word restart first. It may throw some errors when closing the last window, ignore them. Kill it with Task Manager if needed.
  5. Open Word and paste your document. If it's not in the clipboard anymore, import it with clipboard manager first.
  6. Saving as docx should now work.
share|improve this answer

I've just struck a very similar problem --- could save the document in 2003 (.doc) format, but trying to save in .docx resulted in an endless loop of SaveAs dialogs popping up, and no document actually being saved.

The document had pictures but no formulas, and and first I didn't have a clue which parts of the document were corrupted.

If it helps others, I was able to fix the problem by doing the following:

  • With an open document, choose Save As.
  • Set to save in .docx format.
  • [Very important!] Tick the box titled “Maintain Compatibility with Previous Versions of Word”. Word then allowed me to save the document, but indicated it'd fixed some errors. At this point, I could click the Details button for a list of errors which had been fixed.

This enabled me to save a document in Word 2010 format. The document was saved in Compatibility mode, but I could easily revert that by choosing File/Info/Convert to convert it to a full 2010-format document.

share|improve this answer

I finally fixed this by simply following the "Open and Repair" feature in MS Office 2013 (probably in 2010 as well). Check it out - http://support.microsoft.com/kb/893672. This told me my errors (text box and a shape).

Afterwards I put my 2010/13 styles back on while in 2013, saved, and everything took. I hope this helps.

share|improve this answer

I had this issue when I was using a auto-Bibliography with the IEEE style.

I had to remove the bibliography from the document to get it to save.

It saved, but I'm not sure what will happen if I try to add the bibliography back in.

share|improve this answer
    
Thanks, this resolved the save loop for me. I could save once I removed the bibliography, but the loop re-appeared when I put it back. I could put it back after I restarted Word though. In any case, didn't have to copy the content to another document. –  Artyom Aug 3 '14 at 18:12

I had this same problem in Word 2013. Turns out they let you insert an .ico as a picture, but after doing so I got the endless save loop. Took me a while to find the problem, but after taking out all the icons it saved just fine.

Hopefully that's useful for somebody stumbling across this question in the future.

share|improve this answer

I have an alternate solution for this bug - not perfect, but in my case I could save the whole document:

The issue comes from formulas, tables or the like. Make a new Word-Document and copy and paste the text,formulas in parts step by step. Try to save after each pasting. Change or retype the actual part, if the save loop starts again.

In this way I could save a big document with formulas etc.

I hope it helped and excuse the english-grammar mistakes ;)

Good luck!

share|improve this answer
    
+1 You can potentially save some time via bisection, i.e. copy paste half the document, depending on whether it works or not you know that this half has a problem or not, if yes, half the half etc –  Tobias Kienzler Oct 1 '14 at 11:37

In my case it was a table of contents. I just removed it, saved the document, and recreated the table of contents. Cheers

share|improve this answer

In my case the thumb drive where I had been saving the file got damaged. Strangely, I couldn't save it elsewhere as a Word file but I could as an RTF. Repairing the thumb drive (using windows tool) fixed the problem and allowed me to save as a word file.

share|improve this answer

I tried everything here but nothing worked apart from this solution:

Whenever I wish to create a new MS word document and use it, I do not use previous templates. I make a folder and right click inside the folder to choose the New Microsoft Word Document option from the drop down menu and work on that.

I do not use any previously saved templates and do copy paste of the docs that I build, I make a new MS word doc by using the right click option and work on it. I rename it according to the topic that I write on.

The save loop never comes up now and there is no compatibility issue error or other problems like Shift key not working with some other keys.

share|improve this answer
    
So you suggest this is a problem of templates? –  Tobias Kienzler Oct 1 '14 at 11:37

In WORD 2010, if a formula or the text that serves as the target for a table of contents is edited and is left in red-line track changes mode, this can cause this same behavior in the WORD file. Simply undoing or accepting the tracked changes in the formula or regenerating the table of contents can fix the problem.

share|improve this answer
1  
The tail end of your first sentence ("this can cause this same behavior in the WORD file") is hard to understand. You may want to consider clarifying what you mean (by editing your answer). –  lzam Sep 28 '14 at 21:15

In my case I disabled the save option "Allow background saves". This resolved the issue on Windows 7 with Microsoft office 2010.

Path for "Allow background saves": File ---> options --> Advanced --> save

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.