Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am having problems getting a Linux system to boot after apparently successfully installing a system on it. The partitioning is your tried and true Fdisk with the following partitioning

part 1:    /boot     1 GByte
part 2:    SWAP      about 12 GBytes
part 3:    /         the rest

When booting it seems to come up to a GRUB prompt. However, reinstalling grub does not fix the problem. I've also tried to do a couple of reinstallations from scratch.

Any good suggestions as to what's happening and how I should address this?

share|improve this question
    
reinstalling grub does not fix the problem What is the problem, exactly? What errors are you getting, if any? And what operating system are you trying to install? –  Alex Jun 4 '13 at 20:32
    
PS: Thanks for the downvote :-( I thought the question was good....what happens it gets to a grub prompt and goes no further. Ubuntu 12.04.2 LTS. –  mdpc Jun 4 '13 at 20:36
1  
You probably got downvoted because your question is severely lacking in any kind of details - the only thing you've told us is that you're "having problems getting a Linux system to boot", and you've showed us your partition table (which shouldn't really affect the solution to the issue anyways). Are you using MBR or UEFI? Are you able to install successfully using smaller partitions (e.g. less than 2 TB)? –  Breakthrough Jun 4 '13 at 20:49
    
I am using MBR....and have not had any problems with smaller disks. I don't think that this is a partition size problem but a disk size problem. –  mdpc Jun 4 '13 at 20:54

2 Answers 2

Legacy BIOS has limitations when installing system partitions on drives over 2 TB. Split up your system partition or grab a mobo with UEFI.

Do you need a huge system partition? Usually you create a smaller system partition, a swap space double your memory and the remaining to a /home where all your data is generally stored.

share|improve this answer
    
Breaking up the / partitions into smaller pieces did not work. I have a newer BIOS not limited to the 2TB access issue. –  mdpc Jun 4 '13 at 20:56
up vote 0 down vote accepted

After working on this for awhile.....the answer hit. It looks like when the Ubuntu installer sees a disk that is >2TB as the boot disk, it seems to change the partition formatting to GPT.

This means that my partitioning would not work. Why? In MBR formatting, the part of the GRUB binary can be stored after the initial boot record. Unfortunately in GPT formatting, this does not happen and you need some space at the start of the disk to handle the GRUB binary. And we all know that MBR formatting is only good for disks <2 TB.

So in order for the system to work, you need to use the following partitioning:

 Part 1:    Reserved space for GRUB      10 MBytes    ;;BTW, it has a special part code
 Part 2:    /boot                        1 GByte
 Part 3:    SWAP                         12 GBytes
 Part 4:    /                            the rest of the disk.

Thought you all might appreciate the answer.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.