Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Few months ago I changed my Win7 orb using this software. But it changed only the explorer.exe in C:\Windows. To solve that, I copied explorer.exe from there to C:\Windows\system32 and C:\Windows\SysWOW64 (Probably a bad idea).

Things were working fine until a few days ago, it started giving me problems while copying. Sometimes, when I copy/paste, It works fine but sometimes it stays on that dialog box which looks like it is doing pre-copying things like counting number of files/file size etc. But its not. It stays on that screen forever. Now if I try to close it, title changes to cancelling but rest stays the same.

If I try to close it too many times, explorer.exe crashes. And its not related to file-size. It may crash for 4Mb file and work fine for 10Gb file but some other time, it'll do the opposite.

Is there any way to reset my explorer.exe and Is this because of explorer.exe or something else

PS: I forgot to take backup of explorer.exe.

PS2: I didn't install any software or downloaded anything that could harm my computer.

EDIT

I tried System Restore and SFC /scannow but they didn't help.

share|improve this question
    
What a mess. I'd re-image my PC in this situation. I keep a full image of my primary Windows 7 system which I can re-deploy in 15 minutes using my "Todo Backup" imaging DVD. The install I've setup redirects my desktop, My Documents etc. to my "D" drive on a RAID 1 mirror I have for my data partiton- so only a 19GB image of Windows 7 and applications gets re-loaded. It's blazing fast as my system drive is SSD (system image backup kept on the mirror). Every time I see the tiniest glitch (or boot times go over 25 seconds) I just nuke and re-image while I have a glass of wine! –  Austin ''Danger'' Powers Jun 5 '13 at 3:32
1  
Open an elevated command prompt and run sfc /scannow. –  Karan Jun 5 '13 at 4:40
    
Forgot to mention that. I did it but it didn't help –  Sourabh Jun 5 '13 at 5:20
    
@downvoter Please specify the reason for downvote –  Sourabh Jun 5 '13 at 5:24
1  
until you figure it out, try using teracopy for copy/paste operations and see if the problem persists.. –  tumchaaditya Jun 5 '13 at 5:29

3 Answers 3

Couple things to try:

  • Run a System Restore and go back to a point before you changed it.
  • Try running an sfc (System File Check) and hope it puts Explorer back the way it should be.
  • Get a copy of the version(s) of Explorer.exe from another (working) install of Windows 7 64-bit.

You may also want to run some memory tests, and some disk checks.

share|improve this answer
    
Thanks for reply. I tried all of those, but it didn't help. SFC said that system has no problems. I don't have access to any other win7. I do have Win7 DVD, will that be of any help? –  Sourabh Jun 5 '13 at 5:22

There is a way to extract files from windows DVD. Refer this article: http://blog.nirsoft.net/2009/09/17/how-to-extract-missing-system-files-from-the-dvd-of-windows-7vista/

Before you go ahead, a note of caution:

  1. Make sure it is the same DVD from which your current windows installation was created.
  2. Take a backup before replacing any file.

PS: Run the orb changer tool gain. It has an option to restore the start logo which basically restores original explorer.exe which is backed up by the tool at the time it changes the start orb.

share|improve this answer

We had a similar problem. In our case we uninstalled a program called mywinlocker and everything returned to normal.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.