Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Currently my windows 7 has screen resolution 1920x1200 with DELL monitor (Intel Graphics Card). How can I make it default even if NO monitor is connected?

Actually my worry is I am using rdp (rdesktop) to connect remotely after loading one application at startup in this machine, and finally, the monitor will NOT be there anymore, that application needs 1920x1200 resolution with 16 bit ColorDepth.

In current stage, when I start windows 7 without monitor and then login in to it from another machine remotely using rdp (rdesktop), the rdp session is at another resolution, and the application is NOT starting properly, and not properly visible.

UPDATE 1 :My problem is only when, Monitor is NOT connected, otherwise I am getting 1920x1200 resolution perfectly. I am using following command from remote Linux client:

rdesktop -g 1920x1200 ipaddr

UPDATE 2: The problem is NOT actually with rdp or rdesktop. It is of default resolution of windows machine. If monitor is present it gives proper 1920x1200 resolution which is perfect. But, if I remove monitor and restarts the system, windows starts with other resolution, and as my application starts at startup (and which needs 1920x1200 resolution only), the application NOT behave properly.

share|improve this question
    
The -g 1920x1200 parameter to rdesktop works fine here and as expected. What error and/or result do you get? –  mpy Jun 7 '13 at 13:30
    
please see update 2 –  Tejas Jun 7 '13 at 21:41

1 Answer 1

up vote 1 down vote accepted

First set desired resolution using:

ControlPanel → Display → Screen Resolution.

Also set ColorDepth using:

ControlPanel→ Display → Screen Resolution → Advance Settings → Monitor → Color

After this in regedit, manually search for DefaultSettings.XResolution, DefaultSettings.YResolution and BitsPerPixel and change all those to 1920, 1200, 16 (All in Decimal) respectively using next search button F3.
I also added entry of ColorDepth for RDP connection(not mandatory)::

[HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows NT\Terminal Services] "ColorDepth"=dword:00000003 in decimal.

I don't know, which portion of registry did this, but now it works.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.