Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I hope someone can help me with issues I have with my home network. I have a Billion 7700N modem/router and currently I added a Western Digital N600 dual band router. By default (following setup DVD supplied by WD), WD setup itself in LAN to WAN configuration and assigned itself an IP address with different subnet. Which I intend to keep if everything works alright.

So this is my setup:

Billion 7700N:

  • IP: 192.168.1.1
  • Gateway: 192.168.1.1
  • DCHP: on Access point: off
  • Connected to the ISP

WD N600:

  • client IP (assigned by Billion 7700N DHCP): 192.168.1.115
  • IP: 192.168.0.1
  • Gateway: 192.168.0.1
  • DHCP: on
  • Access point: on
  • I connect WD's WAN port to Billion 7700N LAN port.

Internet works fine for all devices either connected to Billion 7700N through ethernet or to WD N600 through ethernet/wifi. When I connected through WD N600 I can see the other subnet (ping and access shared drive) but not the other way around. When I connected to Billion 7700N, I can't even ping any machine connected to WD N600. I can't even ping 192.168.1.115 an IP address assigned to WD N600.

I read some posts on the Net that by default that what I will get with this setup. But I am sure there must be away so that I can connect these two subnet both ways? I have added a static route on the Billion for 192.168.0.0/24 with gateway of 192.168.0.1 but it doesn't help.


Thanks Paul for your response. There is compelling reasons on having 2 subnet. If anything here is why I want to keep it that way:

  • I can use all LAN ports on N600
  • It's good to learn how to make this setup works.

I have added static route to 7700N but I think I set the gateway to 192.169.0.1. I will check and make sure the gateway is 192.168.1.115 and see if I can make it working.

Would you please explain the relevance of disabling NAT on N600? Thanks again.

share|improve this question

migrated from serverfault.com Jun 6 '13 at 1:05

This question came from our site for professional system and network administrators.

    
Pelangi, please register your account over on Server Fault, then use the same login credentials here to get hold of your question again. This way you can edit it and leave comments, etc. –  slhck Jun 6 '13 at 5:42
add comment

2 Answers

up vote 0 down vote accepted

Unless there is a benefit you haven't described for having two subnets, I would suggest you only have one.

The steps for doing this are

  1. Connect N600 LAN port to 7700N LAN port
  2. Disable DHCP on N600
  3. Enable DHCP on 7700N
  4. Manually give the N600 an ip in the 192.168.1.x range (outside the DHCP range)

This will then put all devices in 192.168.1.x range, and be far simpler.

If you want both subnets, then you will need to

  1. Enable DHCP on the 7700N (because the N600 is connected via the WAN port, this DHCP server won't be seen by devices on the N600, so you won't get a conflict)
  2. Add a static route to the 7700N saying that the 192.168.0.x network is accessible via the gateway at 192.168.1.1153
  3. Disable NAT on the N600

If NAT is enabled on the N600 then the devices that are on 192.168.0.x will appear to come from 192.168.1.115 to devices on the 192.168.1.x network. Their address will be NATed to the address of the router. This will prevent you being able to access anything on 192.168.0.x from 192.168.1.x.

share|improve this answer
    
@pelangi Answer updated to include NAT info –  Paul Jun 6 '13 at 4:12
    
Thanks @Paul. Unfortunately there is no option to disable NAT on WD N600. Actually I am surprised that we a router won't allow us to disable NAT. Is it something that we can disable through telnet or any other low level access? Thanks. –  pelangi Jun 6 '13 at 11:08
add comment

You're doing double NAT. Don't do double NAT. You don't actually want two separate subnets on each side of the WD N600, especially not with a NAT gateway in between, because a natural side-effect of NAT (technically a "NAPT" in this case) is that it acts like a bit of a Stateful Packet Inspection (SPI) firewall, and doesn't allow flows/connections to be initiated from the "upstream"/"public" side of the NAT to the "downstream"/"private" side of the NAT.

Disable NAT and DHCP on the downstream device (your WD N600). Make it just act as a bridge, allowing clients to get their DHCP leases from the Billion 7700N.

If your WD N600 doesn't provide a way to disable NAT, then disable DHCP and stop using its WAN port. Just connect its LAN port to the Billion 7700N's LAN port. If it doesn't allow you to disable DHCP, set the DHCP IP address lease pool length to zero (or one, if it doesn't allow a zero-length pool).

This is probably a dup of a zillion other questions on this site, but I'm too lazy to look up the best question to dup it out to.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.