Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am having a couple of issues with a WD Green 3TB hard drive I bought. The OS is Ubuntu 12.02. I tried gsmartcontrol and the drive looks fine, but when I ran badblocks it was a tragedy. I am thinking that there might be a power supply issue. I currently have a 350 W PSU, the mobo is a Zotac Z68 ITX Supreme with an Intel Core i3. Two fans on the mobo (one for the CPU, the other for the GPU) and a big 12cm fan to cool the case. I also have another HD 2.5" Fujitsu MHZ2160B on the same power cable.

Is 350 W enough? How can I check if my HD is getting enough power under load?

share|improve this question
    
The question cannot be accurately answered unless you tell us the brand and model of the power supply. Many generic power supplies cannot supply their full rating, are rated for mains draw not supplied power, or provide much of their power on the wrong rails. Over time PC power supplies have shifted amperage between the 12V, 5V, and 3.3V rails. An old power supply may have ample power available on the wrong rail and not enough on a critical rail. –  kmarsh May 15 at 20:03

2 Answers 2

up vote 4 down vote accepted

The problem is unlikely to be weak power supply, since the processor and motherboard is much more likely to be voltage sensitive than the HD. Also, HD's use 5-10w of power while the motherboard and cards will pull 50-200w, so they are more likely to have issues first.

Many BIOSes will also show current voltages, so if you enter BIOS you should be able to browse around to check your 5v and 12v levels. You can check voltage under load by using a voltmeter on the same power cable as the HD, checking for voltage drop.

share|improve this answer
    
Anecdote: on a couple of servers I built with a RAID set (using disks of different brand) the Seagate ones would temporarily fail (READ FPDMA QUEUED errors) under heavy disk load. After monitoring the voltages we saw how the 12V would sometimes go as low as 11.5 (which I think is still Ok) when the disks failed. We fixed it just using more powerful PSUs (and not trusting Seagate anymore). –  MV. Mar 30 at 6:45

I think it is definitely the power. I just had a problem with my HDD, working too much and doing nothing at the same time. Crashing all the time. Guess what, the SATA cable had problems and I changed it. Problem solved!

I recommend buying a 500W+ PSU to make sure the power IS enough. Mine is 1000W.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.