Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a Gigabyte motherboard with an onboard Realtek HD sound card. The card is working perfectly everywhere, except for a single video format, where the voice is distorted, sounds as if it's been passed through a metal tube.

Been googling for this, but couldn't find an answer anywhere.

The movie plays fine on other systems (got Linux everywhere else), but on this one (winXP-x64-sp2) it just doesn't.

Here are some details:

Type: KLCP WMV File
Audio: 0x000a 22050Hz mono 20Kbps [Raw Audio 0]
Video: Windows Media Video 9 400x300 29.97fps 227Kbps [Raw Video 1]

Codec: wmas
Sample rate: 22050
Bits per sample: 16
Bitrate: 20kb/s
share|improve this question

I would suggest that follow Eric Falsken tip, indeed seems some kind of problem of your sistem codecs, try uninstalling them ALL.

Altrough you could also try to start your computer with some live cd (linux, ubuntu) and test that video file with linux, just to confirm that is some kind of OS problem.

share|improve this answer

This is a WMV file with WMA audio. You should be able to play the file just fine using only Windows Media Player and Microsoft pre-installed windows codecs. It's possible that you've downloaded and installed some other codec which has hijacked WMA from MS's codec, and that might not be fun to debug. What I usually do is using Media Player Classic, go into the options. Go to Internal Filters. Uncheck WMV1/2/3 in the Transform Filters side. Then, Play your video. While the video is playing, right-click on the video, and click on the "Filters" submenu. You should see a few items listed. There will usually be 1 source filter (seen as the file name), 1 Audio Output filter (usually Default Direct Sound Device), 1 Video Output filter (usually something like Video Renderer or VMR9 or Overlay Mixer). And possibly an Audio Switcher. This leaves 2 other filters responsible for actually processing the video and Audio codecs. For a WMV/WMA file, you should see WMVideo Decoder DMO and WMAudio Decoder DMO. These are the MS filters. If you see anything else, that's probably your problem.


If they are there correctly. Then it's time to look into driver issues. But there's one more thing to test while we are in Media Player Classic. Go into the options and into the Output settings page. At the bottom is a dropdown labeled DirectShow Audio. Switch it to Default WaveOut Device and try playing the video. (Close the file that is playing before testing. Changing these settings while playing a video will have no effect. Or simply close MPC and reopen it.) This changes the output device. If you hear any difference at all, then there's probably something wierd going on with one of your drivers. Some sound cards have strange audio effects that you can set, and that's probably what is going on.

share|improve this answer

Try a new version of the Realtek HD Audio driver; this could solve your probs.

share|improve this answer
tried the latest from the realtek website. then tried the latest on giga-byte site. same thing – dyasny Oct 25 '09 at 18:46
What are you using to play the video? Have you tried any total codec pack? Have you tried to play the video on the Linux computer with the same sound output? Is there any way of pref that you did not set right in HD Audio Manager? – Deniz Zoeteman Oct 25 '09 at 18:48
I've tried with the CCCP pack and the latest k-lite pack - same thing. also tried media player, media player classic, GOM, VLC all these work fine on other systems, I'm sure it's something to do with realtek. on Linux I use M-Player with the codec set from 2007 works fine as well. The settings in the Audio Manager are default, I've tried changing them around - didn't change the quality of the sound, just the loudness and some extra effects. – dyasny Oct 25 '09 at 18:57

Can you try getting a codec pack for another audio player and then try? For eg: get a codec pack for WMP, probably VLC isn't able to play it well.

Edit: What player are you using to play this on your linux systems, if its VLC then i maybe wrong.. then its probably just getting an updated driver pack?

share|improve this answer
I've tried with the CCCP pack and the latest k-lite pack - same thing also tried media player, media player classic, GOM, VLC all these work fine on other systems, I'm sure it's something to do with realtek on Linux I use M-Player with the codec set from 2007. works fine – dyasny Oct 25 '09 at 18:48

I suggest trying ffdshow. It has tons of options, but the most notable one related to your question is the ability to set the internal decoder to do the decoding of wmv audio streams (wma) rather than the system's default one. This can be done by opening ffdshow's audio decoder configuration window >> Codecs (top, on the left side list) >> Set WMA from disabled to libavcodec.

Hope this helps !

share|improve this answer

You could try making sure all your Microsoft codecs are up to date

share|improve this answer
up vote 0 down vote accepted

I ended up reinstalling my system with Windows 7, and now everything seems to be working.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .