Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I did a clean installation of Windows 7 on my computer more than a month ago, prior to that I have never had a problem with my mouse. Then about three weeks ago, one day, I was here on one of the stackechange sites, surfing and reading post when all of a sudden my mouse became super-sensitive, it started clicking and right clicking at different points on the screen, all I had to do was touch. It moved from point to point moving files and closing windows, there is a mouse lock key on my laptop, I clicked on it, waited for a while unlocked the mouse and then it works again. I re-opened google chrome (which my mouse closed out of my conscious command), then the weirdest thing happened; every time I click a tab, it closes, every time I try to go back one page, the previous page opens up in a new tab. I googled this phenomenon and i found out it happens when one holds on to the right click. One day, happened and I got furious at my mouse and hit it. The mouse freezes for a split of a second and started moving, but this time around, it works properly. I've tried re-installing the touchpad driver but nothing works.

share|improve this question
Is it a mouse or a touch pad? Did windows do an Update around the time the misbehavior started? – Ben Plont Jun 7 '13 at 0:56
The registry key: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E96F-E325-11CE-BF‌​C1-08002BE10318} Contains mouse drivers. Have you tried deleting the entry for the mouse, and then plugging it back in? WARNING EXPORT THE KEY SO THAT YOU CAN REINSTALL IT IF SOMETHING GOES WRONG. – Ben Plont Jun 7 '13 at 1:37
@BenPlont It is a touch pad. Yeah windows did an update around the time but I did restore it to before the update and there was no difference. – user168105 Jun 13 '13 at 13:48

You must log in to answer this question.