Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a specific scenario, but I wanted to understand how to troubleshoot this generally.

I have a debian machine, with lighttpd and egroupware installed (egroupware installed via an OpenSUSE repository).

I want to install roundcube on this machine, and if I try, apt tells me it will uninstall all of the egroupware packages.

I think it must be that roundcube will bring in a dependency that conflicts with a dependency that egroupware needs. So to satisfy roundcubes requiremnts, the egroupware dependency must be removed, and so egroupware itself must be removed.

My question is - how can I identify the conflict easily? I figure I can work out the dependencies of both, and go though them one by one, but I am hoping there is an easier way to get apt to reveal its decision making process.

share|improve this question
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.