Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

This is similar to How to disable Ctrl+Shift keyboard layout switch (for the same input language) in Windows?, but regards Windows 8.

Here, I can change the keyboard language with Win+Space which is fine, but it also changes with Ctrl+Shift which is not. Is it possible to disable this on Win 8 as well?

share|improve this question
    
Thank you for asking this question... this "feature" has really bugged me, and the way to turn it off is not available from the standard settings UI for languages and keyboards. –  LarsH Feb 22 at 15:31
add comment

3 Answers

up vote 11 down vote accepted

You can disable the sequence Ctrl + Shift in Windows 8.

  1. In "Control Panel" | "Clock, Language and Region" | "Language" click "Advanced Settings" in the left pane.
  2. In "Advanced settings" click "Change Language bar hot keys"
  3. In "Text Services and Input Languages" click "Change Key Seqquence" button and disable the the key sequence.
share|improve this answer
    
interesting, I don't have "Clock, Language and Region". I have Language and Region as separate options in the control panel... –  klyonrad Aug 13 '13 at 11:39
    
Ditto (in Windows 8.1). And there is no "Advanced Settings" button. :-( –  LarsH Feb 22 at 15:35
    
@LarsH: It's not a button, it's a link (on the left). I have it in 8.1. (But then, my version of 8.1 says "Clock, Language and Region", so...) –  T.J. Crowder May 22 at 11:22
add comment

In case you can't find the option as it's described in the other answer

  • Control Panel
  • Language
  • Advanced Settings (on the left side)

*Advanced Settings* (on the left side)

  • Switching input methods -> Change Language bar hot keys

Switching input methods -> *Change Language bar hot keys*

  • In the Tab Advanced Key Settings

    In the Tab Advanced Key Settings

  • Change Key Sequence FINALLY!

share|improve this answer
    
Thank you! I couldn't get the other answer to work, but with this one I was successful. I wish I could upvote this meticulous, illustrated answer twice. –  LarsH Feb 22 at 15:39
add comment

Poor, poor, poor design by M$ (surprise, surprise). The option to change the settings for "switch keyboard layout" require that the user select "Between input languages". I saw this setting twice as I searched for the option to turn the *&^#@%@ thing off (brilliant initial design, using two keys immediately beside each other that can easily be hit together accidentally). Unfortunately, the description mentions changing languages rather than keyboard layouts (these are NOT the same thing, even in the M$ warped view of the world, but you have to open that dialog to discover that there is, indeed, a setting for keyboard layout).

If you are trying to change these settings, follow the instructions above (and then you can curse microsoft quietly and just for fun instead of when you can't type anything comprehensible because of their poor design choices).

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.