Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

OS: CentOS release 4.6 (Final)

I am trying to install the latest emacs which is listed on their website as being v24.3. However, when I try to install with YUM the version is 21.3-19 which is from 10 years ago. What do I need to do?

share|improve this question
add comment

1 Answer

up vote 2 down vote accepted

You use old OS (CentOS) and emacs-21.3-19 is the latest version that exists in CentOS 4.6 repositories. Try to find more fresh version here, or another custom repository, or compile latest emacs version from sources.

share|improve this answer
    
is there a way to add the lates version to the repositories in order to use YUM? –  Isopycnal Oscillation Jun 7 '13 at 20:32
    
It is big headache to support repositories for old OS. Different versions of software have different dependencies. I think it almost impossible. Only if you have your personal repository. –  september Jun 7 '13 at 20:49
    
So does that mean I cannot use YUM? I need to compile from source? –  Isopycnal Oscillation Jun 7 '13 at 21:31
    
.........Yep. :( –  september Jun 7 '13 at 22:24
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.