Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

From what I have read, I understand that Google Chrome's full-screen mode will always present the "This is full screen mode. To exit, blah blah" message by default and that it cannot be modified (nay removed) in any way due to security reasons, and being a Computer Scientist, I can fully appreciate this and the associated reasoning behind this alert being present at all times.

The problem that I have with this is that I am currently working on a novel and am using Google Drive (formerly Google Docs) to do this. I like to work in full screen mode in order to maximise my working area, but whenever I do this in Chrome, the buttons towards the top of the screen are always restricted, as such, because the security message appears every time my cursor goes into the upper-central area.

I appreciate that either shortcuts and/or other browsers could be used, but Chrome is my browser of choice for numerous reasons and I think that this "problem" when 'Google Drive/Docs meets Chrome' is somewhat counterintuitive and has been overlooked by Google. Perhaps an acknowledgement of sorts on the end user's part would have been better, thus "protecting" Google should anything go wrong / be compromised in any way.

Aside from using shortcuts and/or a different browser, can anybody suggest a way to avoid (remember: it cannot be disabled) this as it is rather frustrating?

The screenshot shows what happens whenever I try to click on a button in the upper-central region of the screen in fullscreen mode; you cannot see my cursor of course, but the alert/message appears for a few seconds and then disappears, but when I remove the cursor from this section and return to it in future, the alert appears once again.

Many thanks.

UPDATE

Note that "kiosk mode" is not suitable as I also require the use of other Chrome windows simultaneously. Furthermore, I would also like to be able to restore the window to normal size.

When hovering over the buttons in the upper-central part of the screen in full-screen mode when using Chrome, the 'Full Screen Alert/Info box' appears.

share|improve this question
1  
The popup is so annoying you are better off just using a maximized Chrome window. On Windows you can use Windows Key + Up Arrow to maximize. This is especially true if your using docs in compact controls mode. The other option is to not run in compact controls mode so your mouse goes to the top less often –  Brian Aug 11 '13 at 15:37
    
Thank you, Brian - this is a good suggestion (using non-compacted controls). Duly upvoted. –  SnookerFan Aug 11 '13 at 15:46
add comment

1 Answer

There are reports that starting Chrome in kiosk mode solves this problem.
See Google Chrome – Full Screen Kiosk Mode for instructions, but the main idea is to start Chrome with the parameter –kiosk http://[enter URL here].

This seems to only work if no other Chrome window is open at the same time.
If you want to work around this limitation, try
How to make Chrome open in kiosk mode even if there's already another instance running? .

(source)

share|improve this answer
    
Thank you, but this is not suitable for me - please see above; I have added some further information. –  SnookerFan Aug 8 '13 at 8:51
2  
The Chrome OS beta has 'Immersive mode'. This feature might solve your problem, if it makes it into the Chrome browser. See Immersive mode vs full screen. –  harrymc Aug 8 '13 at 11:49
    
That looks great and does seem to be a possible solution; as you quite rightly refer to, however, as Immersive Mode is not currently part of the Chrome browser, I am still faced with this problem. Thank you, however, for digging this up - your comment has been duly upvoted. –  SnookerFan Aug 9 '13 at 8:59
1  
I am afraid Immersive mode may be your only solution, besides moving to another browser. –  harrymc Aug 11 '13 at 6:39
    
I see; moving to another browser defeats the object of my question, however, so I won't be doing that! –  SnookerFan Sep 19 '13 at 9:16
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.