Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When I get a URL wrong at the top level (i.e. when DNS lookup returns NXDOMAIN), my Firefox browser redirects me to ask.com. How do I remove or customise this functionality? There's nothing obvious in the options dialogue and Google isn't being helpful—probably because I don't know the correct name for the error!

I'm running Windows, Firefox 3.0.14. Not malware, I think I accidentally installed it with realplayer or something.

share|improve this question
1  
what's your isp? installed any new toolbars lately? run a malware/virus scan? –  quack quixote Oct 25 '09 at 20:03
1  
I actually truly think RealPlayer was the first malware ever... –  Arjan Oct 27 '09 at 9:15
    
@tenpn: Since you said it happens when you get the URL wrong "at the top level", I take that as meaning having the hostname wrong. The specific error is therefore a DNS lookup error (NXDOMAIN), not 404 (which a similar error for for HTTP rather than DNS). I've edited this into your question; revert if you think I'm wrong. –  Mechanical snail Aug 9 '12 at 10:07
add comment

4 Answers

up vote 5 down vote accepted
  1. Type about:config in Firefox location bar and press Enter.
  2. Type keyword in Filter textbox and you will see only the preference keyword.URL.
  3. click keyword.enabaled to set it to false. This will disable the search functionality.
  4. If you want to keep the search functionality but use another search engine then double-click on keyword.URL and change the value to say "http://www.google.com/search?btnI=I%27m+Feeling+Lucky&q=" which is the firefox default.
share|improve this answer
add comment

If you're on Windows, check Add/Remove Programs (or its equivalent) for anything called something like Ask.com Search Assistant or URL Assistant and try uninstalling them if they're there.

share|improve this answer
    
Had already removed the ask toolbar from firefox, but uninstalled it as well. No joy. Also removed a dell "browser error redirect tool" but think that was probably for IE not FF. –  tenpn Oct 25 '09 at 20:24
    
There may still be a component or two installed on your system. Sadly some of these "helper" tools install multiple programs on you computer... not so helpful. –  AnonJr Oct 25 '09 at 20:39
add comment

As mentioned earlier, there's probably a "helper" program that came with the Ask Toolbar that is still resident. If its not in the Add/Remove programs, you may want to look at the list of services running as it may have placed itself there too.

Check your Proxy/DNS settings to see if the Ask Toolbar didn't set Ask as the DNS service. It may have changed it in the FireFox settings and/or it may have changed the global Internet Options in Windows.

In most cases, you can clean up a lot of junk left behind by applications by using tools like CCleaner.

share|improve this answer
add comment

This is a tricky one! In my case, the redirect occured in firefox config file, but the clever toolbar people didn't redirect directly to Ask.com or yahoo.com, the browser is redirected to another site which redirects you. This is how i fixed it:

In Firefox type

about:config in the address bar. (Ignore the warning.)

Search for keyword.URL

and change it to Default.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.