Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a MiniITX-based NAS (motherboard - POV ION-MB330) in my network that won't shutdown properly when Wake by PME (Wake on LAN) is enabled in the BIOS. When Wake by PME is enabled and shutdown command is sent to the machine, or the PW button is pressed, it just reboots, it does not stop operating. If wake on LAN is disabled in BIOS, the machine shutdowns normally. My question is - How can I keep the WOL ENABLED and still be able to shut down the machine properly?

There are four disks attached to the system - 2 x 2TB WD green, 2 x 200GB Maxtor. There is also one USB hdd (1tb Samsung). It doesn't matter if it's plugged or not, the result is the same. The NAS runs Debian Linux.

-----------Update------------

The reply to the email I wrote to the manufacturer's technical support


Dear sir

Thank you for having our product

This mainboard is EOL, and there are for some years no bios updates more developed . I am sorry, but unable to help you with this matter

With kind Regards

Point of View / Technical Department


Obviously they don't know what they are talking about.

Does someone have any ideas on how I can get rid of this nasty problem?

share|improve this question

migrated from serverfault.com Jun 8 '13 at 16:57

This question came from our site for professional system and network administrators.

    
Please specify the motherboard model, and more details about the system configuration (e.g., are any USB devices connected, what operating system is used). –  Sergey Vlasov Jun 8 '13 at 16:59
    
Also see: My computer reboots when I tell it to shutdown (in particular, testing without the Ethernet cable connected will help to find out whether the problem is with your Wake-on-LAN config, or something else causing the immediate wakeup). –  Sergey Vlasov Jun 8 '13 at 19:10
    
Thanks for the input Sergey. I added more info to my first post. I've tried unplugging the network cable - the result is the same. I've searched the manufacturer's website for bios updates for the board, but it seems that there are none. I also emailed them and I'm currently waiting for a reply. By the way - there is no offline time after the shutdown at all. It's just like a reboot, it immediately starts up again. –  Mr. Goodkat Jun 8 '13 at 21:30
    
@Mr.Goodkat Still having this issue? Since you mentioned Debian, can you attach the full output of dmesg and pastebin the output of sudo acpidump > acpidump.txt somewhere? –  Lekensteyn Jun 21 '13 at 17:26
add comment

1 Answer

There are a couple ways Wake-On-LAn works. One is to wake up on ANY packet, and the other is to only wake up on receiving a Magic Packet.

You can test this by leaving WOL enabled, but pull out the network cable before shutting down. If it stays off, it's probably set to wake on any packet.

This will be controlled by the OS.

For example, in Windows you would check the properties of the network card, and under the "Power Management" tab, there will be a couple check boxes:

"Allow this device to wake the computer" - Checkmark this if you want WOL to work at all.
and under that
"Only allow a magic packet to wake the computer" - If checked, this will do as it says and only wake on a WOL magic packet.

These are quoted from Windows 8; the wording is slightly different for previous versions of Windows.

share|improve this answer
    
Thank you for helping out techie007. I've experimented with both unplugged and plugged network cable. When WOL is enabled in BIOS, the computer will not shutdown properly. It runs Debian Linux, so there is no need to give steps for Windows. Thanks though. Any other ideas on how can I deal with this? –  Mr. Goodkat Jun 8 '13 at 21:21
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.