Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've been tracking down a confusing problem over the last couple days and I'm hoping someone here might've experienced it before.

First, the short version of the problem: My Zoom 5341J modem provides a great internet connection when hooked directly to a computer, but no internet connection when run through a router.

Location: Michigan, USA ISP: Comcast Modem Firmware: 5.5.4.9J

Now some background. I've had the same set up - an ASUS router and this 5341J modem - for several months. My only complaint is periodic (once or twice a day) 'hiccups' where the modem seems to loose but then re-establish a connection, generally lasting from 10-30 seconds.

I came home from work at about 12:15 am (I work nights) a couple days ago to find that the internet connection was down and when I looked at the modem, only the power and link lights were doing anything. I figured no problem, I'll just unplug/replug the modem and the router. When the modem came back up, all the lights were good so I plugged the router back in but after it reconnected I had no internet connection. I tried power cycling both again, I could get internet connection through the router for a brief time - probably less than a minute - before it would go down again. I ended up resetting both the modem and the router to factory defaults with the issue persisting. When I tried going straight from the modem to a computer, though, it would work - I could get to the internet just fine.

I had an old Linksys router kicking around so I figured maybe my router had died somehow so I tried this Linksys router, same problem. In the course of the testing I went back to straight plugged into the modem and no internet this time. I called Comcast, they confirmed that the signals levels seemed fine but since I was straight in to the modem and no internet they sent a tech out. He came out the next day, unplugged the main coax line from the modem and tested it, it tested fine, plugged it back into the modem and lo and behold the computer hooked straight in to it could reach the internet! The tech suggested it had to do with no unplugging/replugging the modem when I switched from a router to the computer directly - I thought I had, but apparently not. I then plugged the modem back into the old Linksys router, unplugged/replugged the modem then the router, and I had internet through the router. Satisfied, the tech left. As he left, the internet went back down through the router - I should've known, since that is what it was doing before (up for a bit after I powercycle the modem and router but then it dies out.)

I went and bought a new Belkin router, thinking surely it must be the router since a connection straight to the modem works. The Belkin has a setup utility and I followed its prompts but was unable to make a connection when plugged in to the modem and properly powercycled as per the on screen instructions. So that's 3 different routers of 3 different brands that won't work with the modem.

To add to the craziness, during my tests I was able - for a while - to get internet connection over wireless with the Linksys but not to the computer I had plugged straight into the router. I swapped back to my original ASUS and I managed to get the same thing! (ie wireless device could get internet but a computer plugged straight in to the router could not.) After powercylcing a few more times, though, even that stopped (ie I could no longer get internet over wireless, either.) I have not continued tests with the old Linksys to see if I can coax it into internet over wifi again.

So last night I tried plugging a laptop straight in to the modem and it works just fine - so it isn't a matter of it only liking that computer I had been plugging it straight in to. I then plugged it in to a different computer and used Skype on it - worked just fine. Overnight I plugged it in to the original testing computer and left it going overnight. This morning I can still navigate the internet just fine on it. It would've made me feel better if a direct connection to the modem eventually flaked out like the connection through a router does, but no, the direct connection to the modem seems to work just fine.

That brings us up to where I am now - I apparently have a 5341J modem that will not talk to a router, even though as of about 4 days ago it had been doing so without major issue for a few months. I thought maybe the modem got a firmware update that broke things, but no, it seems to be on the same old firmware from several months ago. I figured a reset to factory defaults on the modem would work, but no, the issue persists.

At this point I'll probably talk with Comast to rent a modem from them for a month to see if their modem works properly. If so then I'll know that it's something wrong with my 5341J modem. It just boggles my mind that a direct connection to the modem works but the modem to a router to a computer does not works, especially when it had been working just fine for months!

If you have any ideas or things for me to test, please share them :)

Update: This answer, and others like it on that same question, seem relevant to the discussion here, but I have (at least, to the best of my understanding) done most of these things already. Perhaps next I'll need to try hitting the reset button on the modem when hooking it up to a router and waiting longer before powering on the router.

share|improve this question

closed as not a real question by Ƭᴇcʜιᴇ007, Breakthrough, Olli, Dave M, Scott Jun 11 '13 at 1:00

It's difficult to tell what is being asked here. This question is ambiguous, vague, incomplete, overly broad, or rhetorical and cannot be reasonably answered in its current form. For help clarifying this question so that it can be reopened, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

1 Answer 1

up vote 0 down vote accepted

I finally got my Internet connection back up and the modem isn't the problem! Surprisingly, the modem, the router, and my ISP (Comcast) are all off the hook for this one (at least directly, maybe one of them is at fault for not handling the error more gracefully.) The problem was a hub a ways down the network that somehow managed to take out Internet access for all devices on my network! More specifically, the power outlet that this hub was hooked in to had some sort of problem and caused that hub to freak out. Here's the story of what I had to do to find this out.

Read around some online and found some mentions of the need to reset the modem - not just unplug it, but actually hit the reset button - when you plug it in to a new router. So I unplugged the modem from my computer, turned it off and back on, once it came back on held down the reset button on the back until the lights flashed, waited for it to go back to blue lights (took a few minutes), the hooked it up to the router and plugged my computer into the router. It worked! I tried a few different websites, worked fine, tried a speedtest and got the same results as when I had been straight in to the modem (or there abouts), so all's well. Since it had been dropping internet conneciton over the router after a few minutes before, I waited longer this time - tried some more sites, still going fine. I then plugged back in the other cables in the modem, the ones that go into wall plugs and through those to the other devices in the house. Go back to my main computer (which is off in another room from modem and router), turn it back on, and no internet! Come back to the computer hooked up straight to the router and no internet there, either!

Then I tried reseting the modem again - start it resetting, unplug the router, wait until the modem finishes and the lights come back on as normal, plug the (original ASUS) router back in, and I have internet again briefly (testing at the computer hooked straight in to the router) but then the internet drops again. So I unplug two of the other conections on the router to try to narrow it down - at this point the only two things connected to the router are 1) the computer in the same room with the router and modem and 2) a computer on the other side of a wall from the modem (cat5 plates on both sides of the wall, cable from router to wall, cable from wall on the other side straight to the computer) and internet is just fine! The two cables to the router that I unplugged are 1) a Mac Mini in the same room with the router, modem, and other computer 2) a cable that goes to a wall plate which goes down to a hub which then splits to two other rooms in the house, including the room where my main computer is. So I plugged the cable from the Mac Mini back in - the Mac Mini hasn't even been on during all this testing, it has been turned off for a few days. The internet stays on. So apparently the problem has to do with the cabling going to these other two rooms in the house not getting along with the router.

Time to start narrowing things down on that line to the two rooms. In one room, the room with the TV, the wall plate goes into a hub which runs to some TV-related devices (XBox 360, Apple TV, etc.) I went and unplugged that hub from the wall. Back in the modem/router room, plug the cable to the two rooms back into my router, internet still goes down, so it isn't the splitter in the TV room. Next I figured it might be the cable from the router to the wall that goes to those two rooms. Unplug that cable from the modem and from the wall - at this point internet connection is back up, as expected (since it seems to be having this cable plugged in that causes the internet to go down for all devices wired into this router.) Plug in a different cable from modem to the wall plate serving those two rooms, Internet is slow to respond (takes 10-15 seconds for a page to decide to load) but Internet still works! (testing on the computer in the same room as the modem and router, directly connected to the router.) ...but then I try a few more websites and the Internet goes down. So hmm, it takes it a bit of this one cable being plugged in for the Internet to drop, interesting. For grins, wait a bit and try a few more web pages - Internet is back up! ...but it is quite sluggish, sometimes it takes a long time for a page to load, other times the page will start loading right away but an image won't load, that kind of thing. Try a few more sites and the internet goes down again. Unplug the cable from wall to faceplate serving those two rooms, internet comes backup after 5-10 seconds. Web pages load quickly, the pages with images that wouldn't load before now load just fine, everything is peachy. Wait a bit, try some web sites again, still peachy.

There are still two hubs on this problem line - the one on the other side of the wall plate that splits to the two rooms and the one the my main computer is hooked up to (which also has a laptop and a PS3 hooked up to it.) I figured I'd check out the one on the other side of the wall plate first. I took a laptop and took the line coming out of the wall and plugged the laptop into that line - so now it is router with cable to problematic wall plug that normally serves the two rooms, to my laptop (rather than to the hub which splits to the two rooms.) Internet! Alright, perhaps it is the hub here that has problems. Unpluged it and tried another hub I had kicking around, back to where we were - internet down on all computers hooked up to the wired network. Still one hub left, the one that my main computer is conencted to. I went and unplugged that hub from the main line going to that room and the Internet came back to all other computers! I then took the hub that I had just swapped out (that had been serving to send the signal on to the two rooms) and plugged it in in place of the hub my main computer was hooked up to, internet still works!

...but no internet on the devices hooked up to that hub I just swapped out (including my main computer.) Plugged my laptop in to that hub, no internet. Unplugged the hub from the main line into that room and plugged my laptop straight in there, it worked. Plugged just my laptop and the line coming in into the hub, no internet. Then it dawned on me - the wiring in this house is not the greatest (older house that got added on to in phases a few different times) so I plugged the hub into a different outlet on the other side of the room - laptop still hooked up to that hub and Internet on it worked! Plugged my main computer back in to that hub, it now works. I'm posting from that main computer now. Apparently this other hub at least had the courtesy to only cut off Internet in that room rather than the whole network when plugged in to the problem power outlet. At this point I need to mention that when I unplugged the original hub that my main computer was hooked up to, the lights were all blinking and when I swapped it out with this other hub (but on that same problem power outlet) the lights were blinking - it isn't that there is no power from that outlet, but that something about the power is problematic.

In conclusion, then, it seems that - someway, somehow - one hub having a problem because of a power outlet flaking out managed to take out internet access for all wired devices on my network (and just about drive me crazy trying to track it down)!

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.