Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've installed Microsoft's Virtual PC on Windows 7, but when I try to start a virtual machine I get the following error message:

<Virtual machine name> could not be started because hardware-assisted virtualization is disabled. Please enable hardware virtualization in the BIOS settings and try again. If hardware virtualization settings is already enabled, you may have to disable Trusted Execution Technology (TXT) setting in BIOS or update the system BIOS.

However, if I download and run the Hardware-Assisted Virtualization Detection Tool, it gives the following positive message:

This computer is configured with hardware-assisted virtualization.

This computer meets the processor requirements to run Windows Virtual PC. If this computer runs a supported edition of Windows® 7, you can install Windows Virtual PC.

I've also used the MSR Walker in the third-party utility CrystalCPUID to examine MSR 0x3a on both processors on my system, and it's 0x5 (0x4 = VT enabled, 0x1 = VT lock), as expected.

Does anyone have any ideas of what else to check? Thanks.

share|improve this question
    
Can you give some details on the CPU/Motherboard combo? Almost seems as though it is acting like it has the support but when it tries to use the feature it fails... –  Matt Oct 26 '09 at 17:52
add comment

8 Answers

not really the best solution, but if nothing else works - Windows Virtual PC now has a patch enabling to work on non VT-X machines, so you could try that, although it would be slower.

share|improve this answer
add comment

I had the exact same issue when first using Windows 7 Virtual PC.

To fix it I switched off VT in the BIOS and did a cold boot to Windows, then switched it on again in the BIOS and cold booted again.

VPC now works fine.

share|improve this answer
add comment

In the BIOS is VT actually turned on? Many motherboards come with this disabled by default.

share|improve this answer
    
Yes, VT is enabled. –  Vesa Huovi Oct 25 '09 at 21:16
add comment

You may want to install another VM product just to test and make sure that it works. I, personally, use VirtualBox. It has support for Intel and AMD hardware assisted virtualization. At the very least you can see if it's an issue with Virtual PC or not.

share|improve this answer
    
Curiously, VirtualBox also says that VT is enabled, but then refuses to use it with error "VirtualBox can't operate in VMX root mode." –  Vesa Huovi Oct 25 '09 at 23:52
add comment

switch the comp off by the button the switch it back on then look when it is starting up for the BIOS setup and try it from there

share|improve this answer
add comment

In some BIOSs you need to enable VT in more than one place. Look in both the Chipset section as well as the CPU section for virtualization options.

share|improve this answer
add comment

The error message you're getting from Virtualbox indicates that it cannot get exclusive access to VT and will fail to start. This usually happens if there is an application running that is making use of the VT when virtualBox is run.

I appreciate this is not specific to MS Virtual PC but it may be a clue...

share|improve this answer
add comment

I enabled it my Vaio, it was usb-boot-disk based hack. Once in DOS-mode you get the cmos as a file using SYMCMOS.EXE, change the correct register to [0001] and flash the cmos with the modified file. But after rebooting, Virtual PC's section on Virtualization and MS' HAVtest say I don't have VT-x... so strange.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.