Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have WiFi router connected to the Internet through pppoe. Router has latest version of firmware installed. I have no any antivirus software running and firewall enabled.

My router is ASUS RT-N10LX(http://www.asus.com/Networking/RTN10LX/)

My net is   : 192.168.1.0/24  
WiFi gateway: 192.168.1.1  
WiFi clients: 192.168.1.2(OS Windows 7 Professional (x32)),  
              192.168.1.3(Android 4.xx)

I have access to the Internet from any connected devices. I can ping WiFi router from any devices which have wireless connection to it. From webadmin of my WiFi router, I can see IP addresses of all devices connected to it.

I cannot do ping between devices.
I have "Destination Host Unreachable" message.

But I can do ping from my PC if it connected by cable.

I already did:

  i)netsh int ip reset resetlog.txt  
 ii)netsh winsock reset catalog 
iii)netsh -c interface ipv4 add neighbors "Network Card Name" "192.168.1.3" "xx-xx-xx-xx"



What I need to do to resolve this?
__
Thank you in advance for any help.)

share|improve this question

migrated from serverfault.com Jun 8 '13 at 17:41

This question came from our site for system and network administrators.

    
Can you ping the devices from your router? Many routers offer a ping test tool via webinterface. Also do you have another windows/linux client to test with as this would be easier to debug. Also please include output from ipconfig /all as well as a route print – leepfrog Jun 8 '13 at 17:55
    
My router has no tool for pinging. I have no any additional OS to test. Here are listings: dropbox.com/s/ohypa91hb5pc3tz/rtprint.txt dropbox.com/s/taomj5k9bmiupul/ipconf.txt – headroot Jun 9 '13 at 6:46
up vote 4 down vote accepted

Many wireless access points have "client isolation" enabled, which prohibits direct communication between connected devices. It's likely you just need to disable that.

share|improve this answer
    
I've already checked my access point for 'client isolation'. It's disabled. – headroot Jun 8 '13 at 17:09

I found solution. I've done factory reset for my router and issue was solved.
Thanks to all for helping.

share|improve this answer

If you are looking for that, it is in Wireless -> Professional menu as "Set AP Isolated" and I had to set it to "Yes" and "Apply" and then back to "No" and "Apply" and now it works.

share|improve this answer
    
That presumably depends on the exact device involved. – vonbrand Mar 21 at 0:07

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.