Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have Windows 7 on my bootcamp partition and everything was working fine until now... now, when I close the lid, the computer doesn't go to sleep completely (fans are running)... when I reopen it, the screen remains black and I have to hard reset the machine.

Details: when I close the lid the computer keeps running and the white LED turns on (not blinking). When I open the lid the LED turns off but the screen doesn't appear (computer is still running). Closing the lid again causes the light to turn on again and so on...

I installed the latest Win7 bootcamp drivers, updated NVidia driver with even newer version and tried to disable the MacDrive service (I suspected MacDrive could be the culprit because I installed it recently).

I ran “sfc /scannow” to check for and repair corrupted system files, but it also didn't help.

What else could I do? Can this be related to the fact that I'm running Windows on a Mac, or is it probably the problem in Windows (something got screwed)?

share|improve this question
    
Quite likely a driver issue. Did any of them get updated recently before this started happening? –  Karan Jun 8 '13 at 22:46
    
not really... I checked the list of devices and couldn't think of any that received a driver update recently... which one could be causing this besides the graphics driver? thank you –  David Krmpotic Jun 9 '13 at 9:42
    
The graphics driver would be the most likely suspect. If that's not it it's difficult to track down the exact cause of something like this. See if the event log has anything to say. –  Karan Jun 9 '13 at 14:33
    
Event Viewer doesn't say anything... just "Entering sleep" and "Waking up from sleep".. no errors... I guess I'll have to restore the Win7 partition from an image.. don't have the drive with the image with me right now.. in a few days I'll do it and observe at what point (if) the problem reappears... –  David Krmpotic Jun 9 '13 at 18:10

1 Answer 1

up vote 0 down vote accepted

The reason for behaviour was MacDrive Pro 9.0.5.14 after all... disabling the service was not enough.. uninstall resolved the issue as did update to v9.0.6.4

share|improve this answer
    
I ended my trial with MacDrive PRO and bought MacDrive Standard v9.0.6.4 and the problem is back again :s Will write to their support. –  David Krmpotic Jun 17 '13 at 18:07
    
also discovered that my shutdown problem (it would halt at shutdown screen) is related to the same issue with sleeping... the issue reappeared after I installed the standard edition of MacDrive. –  David Krmpotic Jun 17 '13 at 18:10
    
the acknowledged it and will issue a fix in the next version... in the meantime you can write them to get a non-final replacement .sys file –  David Krmpotic Jun 19 '13 at 0:12

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.