Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have strange problem with sound on my Debian wheezy powered notebook. Sound is not playing through jack output, but speakers are working just OK.

lspci | grep Audio
00:1b.0 Audio device: Intel Corporation 5 Series/3400 Series Chipset High Definition Audio (rev 06)
01:00.1 Audio device: NVIDIA Corporation High Definition Audio Controller (rev a1)


cat /proc/asound/card0/codec* | grep Codec
Codec: IDT 92HD75B3X5
Codec: LSI ID 104


    aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: STAC92xx Analog [STAC92xx Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 7: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 8: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 9: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

My ~/.acoundrc

pcm.!default {
    type hw
    card 0
}
ctl.!default {
    type hw
    card 0
}

A have checked if Headphone output is not muted in alsamixer too.

Is there a possibility to automatically switch to JACK when headphones is connected? It worked on Ubuntu 12.04.

share|improve this question
1  
Does it work if you connect external speakers instead? I assume you've tested that the headphones work right? Are you using alsa or pulseaudio? Check the sound options in pavucontrol if the latter. –  terdon Jun 8 '13 at 19:37
    
Yes I have tested external speakers instead with no success. I tried pavucontrol too, but only internal speakers are working. –  Ch4rAss Jun 8 '13 at 19:47
    
OK, just a shot in the dark here but these are the sound related modules currently running on my Debian : snd,snd_pcm,snd_hwdep,snd_usbmidi_lib,snd_usb_audio try loading (modprobe) each of them just in case that makes a difference. –  terdon Jun 8 '13 at 19:51

1 Answer 1

I had the same problem with Wheezy on an eeepc. It turned out to be a configuration problem. This is how I solved it:

  1. Open alsamixer in a terminal
  2. Press F6: select sound card. I had two choices: a) default b) HDA Intel. Highlight HDA Intel and press enter
  3. More configuration options should now be available in alsamixer
  4. Press the right-arrow key until you find an option named auto-mute
  5. Enable auto-mute

Hope it helps

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.