Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I ssh into my headless remote server with X11 forwarding. All my remote GTK apps from remote server look rather ugly. My default GTK theme is not applied. I think this has something to do with GTK engine or whatever GTK inside magic from the remote server.

I had the similar problem before, when I start my fluxbox WM without starting the gnome-settings-daemon, and all GTK apps look bad. Having run the gnome-settings-daemon after my fluxbox WM is started, GTK apps look fine.

However, I don't think I can follow suite this time on my headless remote server, which doesn't have xorg installed and only boots into console.

UPDATE:

I tried to start gnome-settings-daemon from xterm from remote server and get the following. So I was right, gnome-settings-daemon is out of the question for this case.

...
failed to get device list: The name org.freedesktop.UPower was not provided by any .service files
Unable to register client: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.SessionManager was not provided by any .service files
Failed to get session for pid: GDBus.Error:org.freedesktop.ConsoleKit.Manager.GeneralError: Unable to lookup session information for process '5851'
...

Any way to get my GTK engine (or whatever) started properly?

Thanks

share|improve this question
    
You local theme has nothing to do with your remote server. Why would it be applied? Any X11 apps launched from the server are affected by the settings on the server. Unless you have a working GTK setup there, they will look ugly on your local machine. –  terdon Jun 8 '13 at 20:01
add comment

2 Answers 2

up vote 0 down vote accepted

This is what helped me on Ubuntu Server:

apt-get install gtk-chtheme

The same goes for RHEL6 (and it's clones):

yum install gtk-chtheme

Afterwards you can run this tool through your SSH session with X11 forwarding:

[local]# ssh -CY <remote_server>
[remote]# gtk-chtheme

Next select a theme, say Clearlooks (or install more themes if there are none that suit you). From now all your apps should look way better. This tool will create a file in your home dir (~/.gtkrc-2.0) in which it'll store your settings permanently.

Please note that this seems to apply only to GTK2.x apps, and not GTK3.x.

share|improve this answer
    
That was quite long ago, and now I've totally forgot what was the circumstances. I don't believe it has anything to do with the gtk theme themselves, but I do believe your answer is heading to the correct direction. Thanks –  xpt Dec 3 '13 at 0:23
add comment

Try installing the "light-themes" package on your server.

sudo apt-get install light-themes

This includes "ambiance," the Ubuntu default, and gnome apps should start using that theme once it is installed.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.