Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've used my D-Link DSL-526B for more than three years, but recently it cannot connect to the internet. So far I've been able to isolate these symptoms:

  1. DSL and Internet lights is off
  2. I've tried numerous time restarting it, nothing happens
  3. I've tried hard-resetting it, still nothing happens
  4. I've flushed my OSX DNS Cache just in case
  5. I tried accessing its web-UI dashboard at 192.168.1.1, it cannot be accessed. I pinged it, it shows RTO responses

My questions would be: 1. What is possibly happening? 2. How to fix it I need it to back online as soon as possible?

Thanks. I really appreciate your responses

share|improve this question
1  
Are you certain it's not a simple case of hardware failure? –  Karan Jun 8 '13 at 21:04
    
If this is what @Karan hints at, try contacting your ISP. As usually the modems are just rented from those, you should be able to get a replacement—or at least have it checked. –  slhck Jun 8 '13 at 21:25
    
Since there are no lights, I'd first suspect a power issue. Simply measuring the DC voltage at the little power plug is not sufficient. I've had some power adapters (they happen to be for D-Link switches) that output 5 volts with no load, but dropped to 4 volts when loaded, which is insufficient to power the switch. If you don't know how to open up the modem or don't have a volt/multi-meter, then look for a replacement power adapter to test with. –  sawdust Jun 9 '13 at 1:51
    
@Karan I thought of that at first but I'd like to check other possibilities as well –  Fikri Rasyid Jun 9 '13 at 2:37
    
@slhck i bought this one after the one rented by the ISP broken. I thought due to voltage issue. –  Fikri Rasyid Jun 9 '13 at 2:44

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.