Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

some time ago a disabled swap. I need to enable it now and i was not managed to do it with help of

sudo launchctl load -wF /System/Library/LaunchDaemons/com.apple.dynamic_pager.plist & reboot

my virtual memory properties:

sudo defaults read /Library/Preferences/com.apple.virtualMemory
{
    DisableEncryptedSwap = 0;
    UseEncryptedSwap = 1;
}

and swap usage is

sysctl vm.swapusage
vm.swapusage: total = 64.00M  used = 0.00M  free = 64.00M  (encrypted)

At this very moment i have 4 gb active memory used and 1 gb wired and 2 gb inactive. my mac book pro has 8gb RAM. Activity monitor shows that swap is not used( i mean swap = 0 bytes, page outs = 0 bytes)

Can anybody help me to enable swapping back?

UPDATE: I just loaded all 8 gb that my mbp has and osx started to use swap file.

share|improve this question
    
Are you sure it's not enabled? It won't actually be used until you run out of free memory (i.e. when wired+active+inactive reaches the machine's physical memory). Also, how did you disable it in the first place? –  Gordon Davisson Jun 9 '13 at 3:39
    
i unloaded dynamic_pager with "sudo launchctl unload -w /System/Library/LaunchDaemons/com.apple.dynamic_pager.plist" U are right. i have loaded all 8gb and osx started to use swap file. I was sure that osx will not wait untill i will use all of my memory. Thanks. –  Maxim Korolyov Jun 9 '13 at 7:38
add comment

1 Answer

I switched on swapping by

sudo launchctl load -wF /System/Library/LaunchDaemons/com.apple.dynamic_pager.plist & reboot

As soon as I used all 8GB of memory, my not book's swap file started to grow. Profit!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.