Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I recently updated to Firefox 3.5.3. and installed Roboform 6.9.97. (along with some other add onns). Through process of elimination came to a conclusion, that it was RF's fault.

It makes FF run dead slow (I mean, click on a login - it takes from 5-10 sec before opening a new tab, even scrolling is slow, and the memory footprint is huge - about 1,5Gb, compared to a non noticable one before.

Since I haven't had any problems with RF before, neither with FF, and haven't seen such behaviour on their forums reported, does anyone here know what could be the source of the problem ?

share|improve this question

3 Answers 3

up vote 1 down vote accepted

From Here

Try running Firefox in safe mode.

Start> Mozilla Firefox> Mozilla Firefox (Safe Mode).

If it works, then it is an extension or theme effecting it. You might have to create a new profile in case your profile is corrupt.

You might try FireTune. It makes settings to help speed up your browsing. I haven't used it, but have made similar settings manually in Firefox.

alt text

share|improve this answer
    
I have deleted one of them ;) –  joe Oct 25 '09 at 22:01

Yes I can confirm that it is Roboform making Firfox slow. Have this problem for long time, about 6 month. When disabling Roboform plugin everything is working normal. If some page has many form field Firefox get slower...

share|improve this answer
    
Try secure login .. I gave up on RoboForm and am now using this instead. Workks like a charm. No reduction in speed. –  ldigas Mar 5 '10 at 14:12

The huge amount of time that RoboForm is taking appears to be that it is scanning each page to determine if it will pop-up a window offering to fill forms from your identity.

Under RoboForm->Options go to AutoFill In the area "When AutoFill dialog pops up" Select "Only from Passcards" NOT "From Passcards & Identities" and "AutoFill from Passcards only on pages with Passwords" (this is default)

Then hit the "OK" button.

Changing this made loading pages dramatically faster. For instance, just refreshing the Google home page went from a multi-second wait with CPU at 100% to a brief 20% CPU hit.

The current version of RoboForm, v7.7.6, is significantly better, even prior to making this change, than the last version I had installed, v7.6.7.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.