Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm just switching from windows to ubuntu, just that you know I'm a linux noob. I've compiled monodevelop (4.0) from sources, because only the old 2.x version can be installed with apt-get. Then my project didn't run, because there was no VB.NET compiler for .NET 4.0. So I thought I'll just compile the new Mono 3, too (only 2.x can be installed with apt-get).

Mono soruces downloaded, compiled, installed, seems to be working:

$ mono --version
Mono JIT compiler version 3.0.12 (master/e4a5774 So 9. Jun 12:41:41 CEST 2013)

But now monodevelop isnt starting anymore, over my desktop icon nothing happens, then I looked what it returns in the terminal:

$ monodevelop
System.TypeInitializationException: An exception was thrown by the type initializer for     Mono.Unix.Native.Syscall ---> System.EntryPointNotFoundException: Mono_Posix_Syscall_get_at_fdcwd
  at (wrapper managed-to-native) Mono.Unix.Native.Syscall:get_at_fdcwd ()
  at Mono.Unix.Native.Syscall..cctor () [0x0000a] in /home/manky/Work/mono/mcs/class/Mono.Posix/Mono.Unix.Native/Syscall.cs:2168 
  --- End of inner exception stack trace ---
  at MonoDevelop.Core.LoggingService.RedirectOutputToFileUnix (FilePath logDirectory, System.String logName) [0x0001e] in /home/manky/Work/monodevelop/main/src/core/MonoDevelop.Core/MonoDevelop.Core/LoggingService.cs:177 
  at MonoDevelop.Core.LoggingService.RedirectOutputToLogFile () [0x00041] in /home/manky/Work/monodevelop/main/src/core/MonoDevelop.Core/MonoDevelop.Core/LoggingService.cs:140 
FATAL ERROR [2013-06-09 13:27:54Z]: MonoDevelop failed to start. Some of the assemblies required to run MonoDevelop (for example gtk-sharp)may not be properly installed in the GAC.
System.IO.FileNotFoundException: Could not load file or assembly 'gtk-sharp, Version=2.12.0.0, Culture=neutral, PublicKeyToken=35e10195dab3c99f' or one of its dependencies.
File name: 'gtk-sharp, Version=2.12.0.0, Culture=neutral, PublicKeyToken=35e10195dab3c99f'
  at MonoDevelop.Ide.IdeStartup.Main (System.String[] args) [0x0005c] in /home/manky/Work/monodevelop/main/src/core/MonoDevelop.Ide/MonoDevelop.Ide/IdeStartup.cs:533 

But i've double checked if gtk-sharp is installed. Also:

$ ls /usr/lib/mono/gac/gtk-sharp/2.12.0.0__35e10195dab3c99f/
gtk-sharp.dll  gtk-sharp.dll.config

I tried to recompile monodevelop, but now it isn't compiling anymore, it seems like it can't find the gtk-sharp and gdk-sharp libraries now, too.

So I don't know what to do next. This problem is driving me crazy, I just want to get monodevelop with VB.NET 4.0 on my Ubuntu-System to work. Can somebody help me?

EDIT: So I uninstalled mono and monodevelop and installed the official old versions for ubuntu, and now its running again. But can someone tell me how to remove the old mono version and replace it with my new compiled one?

share|improve this question
    
seems to be a broken mono install, how did you compile mono? what prefix did you use? do which mono to find out –  knocte Jul 8 '13 at 12:57
    
also, I guess you know that if you compile from sources you should first make sure that you have no mono packages installed, and that you don't install them later –  knocte Jul 8 '13 at 12:58

1 Answer 1

Your problem is probably one of versions. Mono is complaining that it cannot find gtk-sharp, Version=2.12.0.0, which version is installed?

One of the problems of using the latest version of something and compiling from source is that it may depend on newer versions of the various libraries it needs. You will have to install the necessary version of each of the needed libraries.

share|improve this answer
    
I guess 2.12.0.0, look at my ls command I showed above, the folder is existing and populated. –  Alex K. Jun 9 '13 at 16:57

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.