Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I backup my files from my desktop to my FreeNAS box with rsync. Here is the command I use:

rsync.exe  -v -rlt -z --chmod=a=rw,Da+x --delete --exclude="Torrents/Downloads" --exclude="Torrents/Watch" "/cygdrive/D/Storage/" "garni::Storage/"

so this ignores both directories "Torrents/Downloads" and "Torrents/Watch", so it wont delete them on the remote side. it works fine.

This isnt what iam trying to do. I want to exclude the deletes from the remote side but still send any files from local to remote. My current parameters are completely excluding them. How can I exclude the deletes to the server, but still include files from local to server?

share|improve this question
add comment

migrated from stackoverflow.com Jun 9 '13 at 23:53

This question came from our site for professional and enthusiast programmers.

1 Answer

All the delete-related options apply to everything being sync'ed, you can't change them for specific directories.

You can do what you want by running two rsyncs. First use your existing command to backup everything except Torrents/Downloads and Torrents/Watch with deletion. Then backup just the Torrents/Watch and Torrents/Downloads directories, but without the --delete option.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.