Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I want to make an SSH tunnel from my Ubuntu to my PC (Windows 7). I found this tutorial for installing openSSH in Windows. I can connect successfully but when I run:

ssh -D 8080 [user]@[ip]  

I get "Unable to access the Internet". What's wrong with it and what should I do?

Note: I just can run in debug mode (sshd -d -d -d) in another way I couldn't connect.

share|improve this question

migrated from stackoverflow.com Jun 10 '13 at 4:08

This question came from our site for professional and enthusiast programmers.

    
What do you mean by "i cant reach the web"? –  michas Jun 9 '13 at 9:23
    
Unable to access the Internet... –  Erfan Mehraban Jun 9 '13 at 9:28
    
What did you try to do? How did you try it? What software did you use to do it? What happened? Was there some error message? - You need to tell us. We don't have any reliable crystal balls. ;) –  michas Jun 9 '13 at 9:33
    
I used that instruction and all step successfully passed! –  Erfan Mehraban Jun 9 '13 at 10:04

1 Answer 1

ssh -D sets up a local SOCKS proxy. (localhost:8080 in your case)

To "reach the web" on your ubuntu box, you need to configure you browser to use that proxy.

You can configure your proxy depending on the browser somewhere in the preferences. For firefox you might have a look at FoxyProxy.

share|improve this answer
    
i was configured it :| absolutely... –  Erfan Mehraban Jun 9 '13 at 9:27
    
So you configured your browser to use the proxy? You also successfully connected from your ubuntu box to your Windows box with the above ssh command? And your windows box is able to "reach the web"? There was no error message in the whole process? –  michas Jun 9 '13 at 9:31
    
yes ,yes ,yes ,no ... there is no problem! –  Erfan Mehraban Jun 9 '13 at 9:34

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.