Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I changed the time of a windows server 2003 manually (3 minutes). How can I force the clients to sync their time with the server?

The clients run on windows xp - 7 and 8.

Any kind of help is much appreciated.

share|improve this question
add comment

migrated from stackoverflow.com Jun 10 '13 at 6:13

This question came from our site for professional and enthusiast programmers.

3 Answers

up vote 0 down vote accepted

One way is to set the Windows Service Windows Time (W32Time) to Automatically start. Then set an Scheduled Task to run w32tm /resync on whatever schedule you want.

If you are trying to force this to happen, the only way I am aware is to create a Domain Policy to do both.

We (Microsoft) do not guarantee and we do not support the accuracy of the W32Time service between nodes on a network. The W32Time service is not a full-featured NTP solution that meets time-sensitive application needs. The W32Time service is primarily designed to do the following; Make the Kerberos version 5 authentication protocol work, and Provide loose sync time for client computers. The W32Time service cannot reliably maintain sync time to the range of 1 to 2 seconds. Such tolerances are outside the design specification of the W32Time service.

share|improve this answer
    
thanks for trying to help. w32tm /resync gives me a : Access is denied. (0x80070005) Error. and yes I'm trying to force the clients to update their time. Do you happen to know how to do it in Domain Policy? –  Tera Jun 10 '13 at 4:15
    
opening cmd as administrator, w32tm /resync doesn't show any errors, but still the client time is different with the server.Any other idea? –  Tera Jun 10 '13 at 4:25
    
Is the Client machine on a Domain? If it is, I don't know why. If it is not, then the client is getting a value from an NTP server outside your network. Your options are to either setup an NTP server on your server or have the server resync with the same NTP server the client is using (time.windows.com by default for both I believe). –  Erik Philips Jun 10 '13 at 17:47
    
yes, the client machine is logged in to the domain. How can I check if the server is acting as a NTP server or not? thank you –  Tera Jun 11 '13 at 0:21
    
show 1 more comment

If you properly configure the time service on the forest root primary domain controller all other DC's and their clients will synchronise with their default settings. I can't remember specifically which of the FSMO role holder indicates which server this is, but it is one of "Schema Master" or "Domain Naming Master" role holders. Though in most domains both of those FSMO roles will be on the same server which will typically be the first server in the domain to be setup.

Look at the MS page Configure the Windows Time service on the PDC emulator in the Forest Root Domain. It basically says to run a command like the following on that server so it can be marked as having a good time source that all other domain machines can sync with.

w32tm /config /manualpeerlist:"0.pool.ntp.org 1.pool.ntp.org 2.pool.ntp.org 3.pool.ntp.org" /reliable:yes /update

This will make your server use the following internet NTP servers

  • 0.pool.ntp.org
  • 1.pool.ntp.org
  • 2.pool.ntp.org
  • 3.pool.ntp.org

Setting the /reliable:yes switch will allow all other servers and clients to default to sync with this server on a regular basis. This way all other servers and clients can be left with their default settings. No additional policies, scripts, or mucking around for any domain server, member, or client.

Though I typically also set an option in DHCP to specify a local DC to be a local NTP server for the DHCP clients/devices who are not domain members. There are 2 settings in MS DHCP, one works and the other is old and deprecated and usually doesn't. I'll fill in which is which tomorrow when I'm at work.

share|improve this answer
add comment

Worth noting - if your client and server times are too far separated (aka "drift") then NTP often wont sync up. You'll have to do it manually first to get them within that range, usually about +/-5 minutes and ensure your date is also set correctly on both machines.

Microsoft has a pretty robust document here regarding the Windows Time Service and also includes information for how to set it up within Group Policy: http://technet.microsoft.com/en-us/library/cc779145(v=ws.10).aspx

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.