Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

i add these on sudo gedit /etc/fstab //192.168.0.119/shared/kamil /mnt/backup cifs guest,uid=1000,iocharset=utf8,codepage=unicode,unicode 0 0 and run the sudo mount -a and i got these error

 mount: wrong fs type, bad option, bad superblock on //192.168.0.119/shared/kamil,
 missing codepage or helper program, or other error
 (for several filesystems (e.g. nfs, cifs) you might
 need a /sbin/mount.<type> helper program)
 In some cases useful info is found in syslog - try
 dmesg | tail  or so

and i try the dmesg | tail and here is the result

[   17.552465] EXT4-fs (sda1): re-mounted. Opts: errors=remount-ro,commit=0
[   24.200021] eth0: no IPv6 routers present
[   30.427109] CIFS: Unknown mount option codepage
[   30.427126] CIFS: Unknown mount option unicode
[   30.427136] CIFS VFS: No username specified
[   30.427148] CIFS VFS: cifs_mount failed w/return code = -22
[ 2404.866610] CIFS: Unknown mount option codepage
[ 2404.866625] CIFS: Unknown mount option unicode
[ 2404.866634] CIFS VFS: No username specified
[ 2404.866645] CIFS VFS: cifs_mount failed w/return code = -22

i dont know whats going on. im using ubuntu 11.04

share|improve this question

migrated from stackoverflow.com Jun 10 '13 at 10:16

This question came from our site for professional and enthusiast programmers.

Make sure you have smbfs installed, also try removing the codepage=unicode option from fstab, and you may need to add the option username=guest.

share|improve this answer
    
i cant update my cifs because i think the repo for 11.04 is closed, but i can mount using the manual mount -t on the terminal – reggie Jun 19 '13 at 5:39

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .