Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Windows 7 Dell with a Broadcom 57810 10G Ethernet card. I have installed the Windows Server 2008 R2 associated drivers, but in the device manager the "Ethernet Controller" on the relevant PCIe slot has not installed driver.

What steps can I take to troubleshoot this Ethernet card driver issue?

share|improve this question

migrated from serverfault.com Jun 10 '13 at 13:26

This question came from our site for professional system and network administrators.

2  
Have you tried turning it off and back on again? –  Chris S Jun 10 '13 at 13:25
    
@ChrisS: Yes I have. –  Randomblue Jun 10 '13 at 13:25
    
Failing that, right click the "Ethernet Controller" in Device Manager, select Update Driver, Browse, find the drivers you downloaded, and follow the rest of the wizard. –  Chris S Jun 10 '13 at 13:26
    
@ChrisS: I tried that but the driver installer comes in a "setup" executable, so that specific driver files cannot be found for manual installation. –  Randomblue Jun 10 '13 at 13:28
1  
Extract the .exe from the command line: setup.exe /t:C:<target_dir> /c or use 7Zip (or similar program like WinRAR) to extract it. –  cole Jun 10 '13 at 13:31

1 Answer 1

up vote 0 down vote accepted

The solution was to use the drivers from Magic Driver.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.