Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am using Windows command line to ftp a file. I was able to do it successfully one time, and every time since then doesn't work. I'm not sure what I changed.

After running the put file_name.txt command from within ftp I wait for ~ 3 minutes and I get the following error message:

425 Could not open data connection to port XXXXX: Connection timed out

The server does actually have the file but it is 0 bytes long.

I disabled firewall and I tried quote pasv after doing some searching around the web for this error.

Any advice?

ftp <myhost>.com
Connected to <myhost>.com.
220---------- Welcome to Pure-FTPd [privsep] [TLS] ----------
220-You are user number 9 of 500 allowed.
220-Local time is now 12:30. Server port: 21.
220-This is a private system - No anonymous login
220 You will be disconnected after 3 minutes of inactivity.
User (<myhost>.com:(none)): <myusername>
331 User <myusername> OK. Password required
230 OK. Current restricted directory is /
ftp> cd ftpTest
250 OK. Current directory is /ftpTest
ftp> quote pasv
227 Entering Passive Mode (97,74,182,128,196,125)
ftp> put test.txt
200 PORT command successful
425 Could not open data connection to port 41084: Connection timed out

NOTE: I'm on Windows 8

share|improve this question

migrated from Jun 10 '13 at 20:15

This question came from our site for professional and enthusiast programmers.

We need more information. What is the network structure like?--e.g., is simply a local a router <--> computer? – jhstuckey Jun 10 '13 at 22:27
godaddy shared hosting server --> small business with 1 router --> my computer w/ internal ip. – ajon Jun 11 '13 at 15:00

Check to make sure that your dont have a Firewall blocking you. Check out this Wiki Link and see if anything helps:

share|improve this answer
I have verified the server isn't blocking it, and to the best of my knowledge I checked locally and there was no problem. I disabled McAfee, which also disables windows firewall. Plus I ran the batch as administrator. – ajon Jun 10 '13 at 21:27

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.