Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top .

  1. I'm not a novice in linux
  2. I created a bunch of files with php using file_put_contents()
  3. I can't view the created files via browser
  4. I can view the files from the ftp but can't change/download/delete them(it says file not found)
  5. I have tried to SSH as root and change the permissions and user/group from there, but it says file not found
  6. I have tried opening the files using php with file_get_contents(); it says file not found
  7. I can rename or download the files from File Manager
  8. I did a fair amount of research on this but can't find a solution
  9. I managed to create another file with the same name in the same directory via php, as per screenshot.

As you can see things are very confusing, especially for someone like me that doesn't know too much about linux. But I know one thing, on any OS there can not exist in the same place and time two files with the same name. It's not an ftp error because I checked with file manager too.

share|improve this question

migrated from Jun 11 '13 at 0:11

This question came from our site for professional and enthusiast programmers.

it can happen that one of the filename has special character which is not visible in browser or your file browser is just stripping it. – Shiplu Jun 10 '13 at 20:02
Files are not identical ( size differs, according to listing ). Their names look like identical. Maybe there's space or tab at the end, or it is disk error? What about shell output? – Piotr Wadas Jun 10 '13 at 20:02
You are not really looking at the directory. If you can ssh to the server, do a directory listing from there. – jeroen Jun 10 '13 at 20:02
Sometimes a special dot character that resembles a dot, may not be a do after all, I've seen that before. – Fred Jun 10 '13 at 20:04
I figured it out. I have a file with all the path files on the server and I can just add \n at the end and use that to modify the files. Thanks again. I think deserves the points because he answered first what was the issue. If you would to post as a regular question I would be happy to accept it as the right answer. – razvan Jun 10 '13 at 20:26
up vote 3 down vote accepted

It can happen when one of the file name has special character which is not visible.

Either its not visible in the browser or your file browser is just stripping this character. Many software does it to beautify the output.

share|improve this answer
Indeed, this can be a limitation of the program that does list the files. Back in the days Windows would display a file named "foo.jpg<lots of whitespace>.exe" as "foo.jpg" - it was a common trick used by script kiddies to spread malware. – AnonymousLurker Jun 11 '13 at 1:55

You must log in to answer this question.