Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Whenever I enter "http://www.google.de" (or any other google domain) in the addressbar, it is automatically replaced by "https://www.google.de".

This happens regardless of beeing logged in with my google account or not. There are some hints on the web, that this behaviour can be disabled, but unfortunately google changed something, and these options are not available anymore (see here)

In the network I am at the moment all SSL- traffic is directed over a "man-in-the-middle"- proxy, so that chrome will not let me open the https:// - links (certificate error).

that's why I want to disable this feature. Anyone who can help me with that?

Before I forget: Chrome version is 27.0.1453.110

EDIT: This has NOTHING to do with the omnibox- search... Chrome just rewrites any google- url I enter...

share|improve this question
    
Network admins and their silly attempt to implement security protecting domain resources from promiscuous surfers sure can be frustrating for those users who don't want to play by the rules... –  packets Jun 11 '13 at 9:52
    
you are so true... Problem is: In this constellation I can not use google to search in chrome at all... I cannot use http:// as chrome redirects and i cannot use https:// due to the proxy... right now I search google with IE... –  Torsten Link Jun 11 '13 at 10:06
    
Does this only happen with Chrome? –  Barmar Jun 11 '13 at 10:19
    
Yes, IE does not do this –  Torsten Link Jun 11 '13 at 10:34
1  
That was not my question... Yes I could use another browser, it works with them.. My question was related to using Chrome... –  Torsten Link Jun 11 '13 at 17:43

2 Answers 2

up vote 1 down vote accepted

I'd say it's because their web servers send the HSTS header (http://en.wikipedia.org/wiki/HTTP_Strict_Transport_Security).

share|improve this answer
    
This sound exactly like the behavior I see... I will check, if I can let chrome ignore hsts- requests... –  Torsten Link Jun 15 '13 at 0:15
    
You're somewhat right. Note that Chrome has list of HSTS-enabled domains pre-loaded by default. No need to send separate header for them. Source: src.chromium.org/viewvc/chrome/trunk/src/net/http/… –  Ilya Zakreuski Jun 15 '13 at 8:34
    
The additional comment of Ilya Zakreuski proved: Yes, this is the reason for redirection, and there seems no way, to disable it. SO this is the answer to my question. –  Torsten Link Jun 17 '13 at 8:24

I have the identical behavior in my Chrome installation.

I inspected the process by opening the Developer Tools (F12), switching to the Network tab and opening http://google.de.

At first, I get redirected to http://www.google.de and then I get a 302 reply that redirects me to https://www.google.de. So the behavior is determined server-side.

enter image description here

However, in my case there is a difference between being logged in or not (when logged into Google, I get redirected. When not logged in, I don't).

Given that the behavior is controlled server-side, I would suspect some cookie to be the reason for this. Try the same procedure in an Incognito tab (Ctrl+Shift+N) and maybe clear your cookies.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.