Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to update my Tortoise client but when I run the file (I'm logged in as an administrator), the process fails because it can't write to .../bin directory.

When I right click the mouse, there's no option to run the file as an administrator. I've also tried runas.exe (didn't start the installation wizard) and starting cmd and PowerShell as an admin (which worked well) but failed (same error as when I simply execute the sucker).

What's up with that?!

share|improve this question
up vote 2 down vote accepted
  1. Open Task Manager or your favorite task manager replacement.

  2. Locate the TSVNcache.exe process and kill it.

  3. You'll now be able to complete the installation regularly.

The installer will be unable to remove the bin folder because the TSVNcache.exe process still runs in it (even though the file has been deleted, the process is still in memory).

This causes the installer to be unable to remove the directory and it will falsely assume that it requires more permissions than it currently has and it will also falsely assume that it isn't running with elevated privileges (even though it probably already is).

share|improve this answer
It worked after two additional operations (not sure if both are required, though, because I got annoyed and changed both things at once). See my edit to your reply. And huge thanks! – Konrad Viltersten Jun 11 '13 at 11:20

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .