Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am having an issue with an enduser getting this error.

After a brief Google search, I found the article here. When I launch Adobe Acrobat X I recieve the following error:

Acrobat Failed to Load core DLL.

I ran the rootkit removal tool, a scan with SEP, a scan with MalwareBytes, I did the clean uninstall/reboot/reinstall from the tool provided, and to no avail, it still provides me with the same error.

share|improve this question
1  
Provide the log file, the error, or something that helps you figure out the cause of your problem. Have you tried to reinstall Acrobat? – Ramhound Jun 11 '13 at 13:47
    
As previously mentioned, I provided the error, already stated I uninstalled/reinstalled and as an IT professional I have no idea how else to proceed. Below you will find that there are no errors logged in the event viewer. After following reading what @Dave-Rook mentioned, I am still stuck in the same point. – Jonathan Weinraub Jun 11 '13 at 18:16
    
If you state this in your question its not clear. Have you tried to run the Acrobat Cleaner Tool and after you reboot attempt to install and run Acrobat XI? – Ramhound Jun 11 '13 at 18:35
    
Yes I did (I guess I wasn't clear with that too because I mentioned it in the original question - also in the followup to Dave Rook). – Jonathan Weinraub Jun 11 '13 at 19:46

I think you should remove Acrobat, then run the removal tool, then re-install Acrobat.

If that doesn't work, then a work around includes (and you didn't state what OS, so this is for Windows since the link in your post is for a Windows fix)

Here is a work around until I figure out the cause. Copy all the FILES, not folders, from C:\Program Files (x86)\Adobe\Reader x.x\reader to C:\

Source

share|improve this answer
    
Yes, sorry, it is Windows 7 x64, in a office environment (Windows 2003 AD domain) – Jonathan Weinraub Jun 11 '13 at 14:56
    
Okay, I copied the files to C root, and I get the same error. When I first started Adobe Reader, I got an error about Protected Mode, but I chose Always Open with Protected Mode disabled, but I get the same error about core nonetheless. I also found when I start Windows and after logging in, I got an error about reader_sl.exe was unable to start correctly (0xc000007b). There were no logs in the event viewer logged pertaining to anything as to what is currently going on. – Jonathan Weinraub Jun 11 '13 at 16:09
    
@JonathanWeinraub - Despite what everything is saying your computer's system image is corrupted ( more then likely by malware that was already removed at some point) – Ramhound Jun 11 '13 at 18:36
    
I literally think ramhounds comment is perfect .. sorry, bite the bullet and reformat. – Dave Jun 11 '13 at 18:59
1  
@JonathanWeinraub - You are installing 64-bit installation of Acrobat ( I assume there is one ) on those machines that are running 64-bit operating systems correct? Have you ran "sfc /scannow" on the trouble machines? – Ramhound Jun 12 '13 at 12:20

I resolved this issue by installing the 32-bit (x86) Microsoft Visual C++ 2010 Redistributable Package.

I figured this out by running Dependency Walker on AcroRd32.dll. There were several errors indicating that a 32-bit DLL was trying to load the 64-bit MSVC 2010 runtime DLLs. Installing the x86 redistributable package fixed the issue.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .