Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I was resizing a partition when my PC freezed and I had no alternative that shut down manually. Unfortunatly that cause my partition table to became corrupt.

My partition table was like this:

Windows  NTFS, Primary

**Extended**
Data NTFS
Ubuntu (ext4)
MAC OS / iaktos L2 (hfs+) 
Virtual Machines (NTFS)
Temp (NTFS)

Windows partition seems intact. I can boot into windows using the MAC OS Live CD Bootloader). Also Ubuntu Live CD can find it. just cant boot. When I strat my computer, I get "No such partition error" and a grub rescue shell.

I tried to use testdisk utility and this is the results: The Virtual Machines and Temp folder are found by testdisk. They look recovarable. It also founds an NTFS partition which i cant idenify. The size doesnt match my data partition (it misses like 500GB). No signs for the other paritions.

My Data parition is where I have all my files. I dont have recent backups. I was preparing to install CrashPlan and a NAS to start automatic backups when this happened :(0 The strange this is if I run fdisk -l in finds a partition /dev/sda5 which I am almost sure it was my data partition.

I hava also read about gpart tool (not gparted). Anyone have any experience with it?

Any advices? What about my Ubuntu and Mac OS partitions? There are no signs of them.

Edit

Here the result of fdisk -l command using ubuntu live cd

    Warning: ignoring extra data in partition table 5
    Warning: ignoring extra data in partition table 5
    Warning: ignoring extra data in partition table 5
    Warning: invalid flag 0x9093 of partition table 5 will be corrected by w(rite)

    Disk /dev/sda: 1000.2 GB, 1000204886016 bytes
    255 heads, 63 sectors/track, 121601 cylinders, total 1953525168 sectors
    Units = sectors of 1 * 512 = 512 bytes
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    Disk identifier: 0xe0c5913d

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *          65   293620004   146809970    7  HPFS/NTFS/exFAT
/dev/sda2       308640778  1953519615   822439419    f  W95 Ext'd (LBA)
/dev/sda5   ?  3786388151  5617242435   915427142+  c5  Unknown

The result of sfdisk

/dev/sda1 : start=       65, size=293619940, Id= 7, bootable
/dev/sda2 : start=308640778, size=1644878838, Id= f
/dev/sda3 : start=        0, size=        0, Id= 0
/dev/sda4 : start=        0, size=        0, Id= 0

Why fdisk can find sda5 but sfdisk cant? My /dev/sda5 (DATA Parition). As I said thats whwere all my important DATA is. I need to recover this partition. Do you think there is anyway to "mount" it to copy its files or whatever?

I am running gpart right now but it is taking lots of time. I could try to recover the paritions showing with testDisk but I am affraid to make things worse.

share|improve this question
add comment

1 Answer

I managed to fix this all using testdisk without loosing any data. I have done a deeper search, following by an MTF fix and voila. My DATA partition was still corrupted but scandisk fix it when i started windows.

Now, its time for backups. I dont want to pass for this again.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.