Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a weird problem with one desktop pc and the wifi connection. I have a Netgear WNDR3800 router, and a TP Link access point working as a repeater. To use the AP as a repeater I have to disable the security from the router (because the router does not support WEP security). But, I have activated the MAC filtering option to only allow known devices.

The weird thing is since I disabled the security on my router, this desktop pc can't connect correctly to the wifi (limited access and no ip assigned). But if I put the security back again, this computer connects correctly.

I have multiple laptops, and cellphones working fine with this router and the AP.

The desktop pc is running W7 and the wifi adapter is an Encore ENLWI-G2 (Realtek 8185 chipset with latest drivers downloaded from Encore's official site).

Do you know what might be the problem?

Thanks in advance.

share|improve this question

migrated from serverfault.com Jun 12 '13 at 16:24

This question came from our site for system and network administrators.

2 Answers 2

I get this alot at work, with some wireless repeaters / access points, when changing the config, some devices which were previously connected must 'forget' that network, then rejoin, as the above comment mentions, removed the 'known' network from the 'manage wireless networks' section under 'network and sharing center'. I think this is mainly to do with some devices not taking in the config change, their for are unable to correctly re connect to the AP.

share|improve this answer

Try removing the network from the "Manage wireless network" screen under Network and Sharing Center.

Join it like you're joining a new wireless network. Select "Advanced Sharing Settings." For whichever profile is currently in use (probably "Home or work"), enable "Turn on network discovery" and "File and printer sharing."

share|improve this answer
    
I tried that, but still does not work. I don't know for what reason, but the network is connected as a Public profile. How can I change it? Maybe that's one of the reason, but really I don't know. It's a very very weird problem, and is giving me a big headache. Thanks! –  Ernes Jun 13 '13 at 0:32
    
Read http://www.tomshardware.com/forum/215-63-change-network-type for how to change network type. About 6 comments down, the one by "Montyuk" –  Wally Jun 13 '13 at 14:01
    
Well, I can't change the network type. Yesterday wifi connected ok, magicaly. But only for a few hours. I don't know why this is happenning. It's driving me mad –  Ernes Jun 15 '13 at 17:50

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.