Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have strange issues with my webcam. In browser it works just fine (in Flash, for example). But when I go to Skype options it says I don't have any webcams. I can see webcam in device manager and it says it's working fine.

I tried to delete config.xml for Skype, as their site suggests, but got nothing.

Also, I have ManyCam Webcam Source in browser webcam selector, although I've deleted ManyCam long ago. Maybe this is related to Skype problem?

When I'm trying to install webcam driver from Acer site, it also says I don't have any webcams.

Notebook is Acer Aspire Timeline 5750G. OS is Windows 7 Home Basic Service Pack 1, 64 bit.

UPD: Okay, installing and uninstalling ManyCam removed it from webcam selector. Browser still uses "1.3 MP Webcam", Skype still cannot see it.

UPD: Connecting USB cam makes it available to browser without problems but Skype still cannot see any. I'm reinstalling Skype right now.

UPD: Nope, didn't help

Device manager info:

1.3M HD Webcam

Hardware ID:

USB\VID_064E&PID_C218&REV_0332&MI_00

USB\VID_064E&PID_C218&MI_00

UPD AGAIN

Okay, it seems I miss registry entries for some MediaTypes (whatever it is), one of them MJPG. That's probably why camera doesn't work. When we load Advanced Graph Manager for media, one of the prefered media types is written as {47504A4D-0000-0010-8000-00AA00389B71} (others have normal names like "YUV2"). Google says this guid belongs to MJPG. Is there any way to restore/reinstall these mediatypes?

share|improve this question
    
What is your webcam? –  harrymc Jun 16 '13 at 9:57
    
It's built into the notebook. –  Kuroki Kaze Jun 16 '13 at 10:10
    
What is it called in Device Manager (normally under "Sound, video and game controllers") and what is "Hardware Ids" in click-right/Properties/Details. –  harrymc Jun 16 '13 at 11:03
    
Updated post with hardware info. –  Kuroki Kaze Jun 16 '13 at 22:35

2 Answers 2

Have you tried installing the Acer Camera software from their website?

Link

share|improve this answer
    
Yes. It says I don't have a webcam :( –  Kuroki Kaze Jun 17 '13 at 7:50

First step is to fully patch using Windows Update and including all optional updates.

Second step is to check that your drivers are at least as recent as those on the Acer Drivers and Manuals page. (Or you can install first the drivers that seem to apply, at least the Chipset and the USB Drivers, then reboot and see if Windows Update can find more recent drivers.)

Third step is to ensure that your applications are up to date (same page on "Application" tab), and especially try out the Acer WebCam Application.

If this still doesn't work, let me know.

share|improve this answer
    
Drives installer says he cannot find a webcam. –  Kuroki Kaze Jun 17 '13 at 7:51
    
Which installer is that? –  harrymc Jun 17 '13 at 7:55
    
    
That's the installer for the Acer WebCam Application. Did you do all the other steps above? –  harrymc Jun 17 '13 at 10:49
    
I'll try when I get home to notebook –  Kuroki Kaze Jun 17 '13 at 14:46

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.