Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I installed Stayfocusd extension to boost my productivity and minimize time spent reading about dietary habits of Mongol soldiers in Genghis Khan's time, or the detailed differences between shallots and onions.

However I must have set some settings wrong as now I'm not able to visit any site. Even the browser settings page won't open and thus I can't remove the extension.

And worst of all I think I set the blocking period to be 1000 hours.

I can't reinstall chrome as I have my bookmarks and other settings in it. Is there a way to get rid of this evil plugin? (Like starting chrome in safe mode or something)

share|improve this question

4 Answers 4

up vote 1 down vote accepted

Go to Preferences>Extensions, and from the list click remove (bin icon on the right)

share|improve this answer
    
Did I not mention - Even the browser settings page won't open. –  Kshitiz Sharma Jun 14 '13 at 4:42
    
I will asume you are on windows 7.. close Chrome and go to C:\Users\<username>\AppData\Local\Google\Chrome\User Data\Default\ Extensions and remove the offending extension –  spacebiker Jun 14 '13 at 4:44
    
Sorry. Ubuntu 12.10 but good idea let me look for that directory on my system. –  Kshitiz Sharma Jun 14 '13 at 4:45
    
Ok, much better. Launch chrome from the terminal with -incognito flag and remove the extension. –  spacebiker Jun 14 '13 at 4:48
1  
Many thanks, that works! Btw removing the extension directory under /home/kshitiz/.config/google-chrome/Default/Extensions would also do the trick. –  Kshitiz Sharma Jun 14 '13 at 4:57

I found an easier way to get rid of it on a Mac. Go to Chrome's Tools > Task manager, find stayfocusd and End process, then you can get to extensions page.

share|improve this answer

This was an epic headache for Mac OS. I don't know about other OS, but with Mac OS these Chrome Extensions are hashed with unique identifiers. I had to /Users/{your username}/Library/Application Support/Google/Chrome/Default/ and search for stayfocusd, delete a whole bunch of keys inside the Preferences file. This led me to a key value laankejkbhbdhmipfmgcngdelahlfoji, I have no idea if this is unique on each system or if this is a Google Chrome Store internal hash value. Anyway, I got Chrome free of this beast by FIRST closing Chrome, then deleting all references to stayfocusd AND laankejkbhbdhmipfmgcngdelahlfoji after searching the /Users/{your username}/Library/Application Support/Google/Chrome/Default/ directory.

share|improve this answer

This is an old question, but I'll answer it anyway in case someone else might find it helpful:

Go to System Preferences, and set the system time forward by a couple days or so. Simple as that.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.