Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have AVI files on a webserver. I can point to them from VLC (via Open Network...) and the file is showing.

However, it is not possible to play the file with Windows Media Player 12 on Windows 7.

The URL looks like this:

http://<ip>:8080/myapp/media/eventVideo.jsp?eventVideoId=WI_9_20130614T143705.619_0200_SPEED-ALARM-LEVEL2_1_ACCEPTED.avi

If I download the file first, then Windows Media Player can play it. But directly from http does not seem to work (WMP shows 'There was an error trying to open the file' or something similar). I have checked the Content-Type and it is ok:

 wdb-laptop:~ wdb$ curl -I http://<ip>:8080/myapp/media/eventVideo.jsp?eventVideoId=WI_9_20130614T143705.619_0200_SPEED-ALARM-LEVEL2_1_ACCEPTED.avi
    HTTP/1.1 200 OK
    Server: Apache-Coyote/1.1
    Pragma: no-cache
    Expires: Thu, 01 Jan 1970 00:00:00 GMT
    Cache-Control: no-cache
    Cache-Control: no-store
    Set-Cookie: JSESSIONID=41EFA3E137F7426BED6FB623EA2840CF; Path=/tms-flux
    Content-Disposition: filename="WI_9_20130614T143705.619_0200_SPEED-ALARM-LEVEL2_1_ACCEPTED.avi"
    Content-Type: video/avi
    Content-Length: 3832904
    Date: Fri, 14 Jun 2013 12:47:06 GMT

The problem is that I have a customer that cannot use anything else then Windows Media Player. This customer claims it work on Windows XP with Windows Media Player 11. (WMP 11 cannot be installed on Windows 7 according to http://en.wikipedia.org/wiki/Windows_Media_Player )

share|improve this question
    
What's the full error message and what URL does it take you to if you click Web help? –  Tim De Baets Jun 15 '13 at 18:53
    
The error message is 'Windows Media Player encountered a problem while playing the file.'. The URL that the webhelp points to is windows.microsoft.com/en-us/windows7/c00d11b1 –  Wim Deblauwe Jun 17 '13 at 6:48
    
I don't know if it has anything to do with it, but the AVI file does not contain audio. –  Wim Deblauwe Jun 17 '13 at 6:53
    
Unfortunately no useful info from the error message or error code. The only advice I can give is that you play around with the settings on the Network tab in WMP's settings. –  Tim De Baets Jun 17 '13 at 19:37

1 Answer 1

You can tell him to use a portable version of VLC :

http://portableapps.com/apps/music_video/vlc_portable

Just execute it and then it will extract the software into a folder, if he cannot, just do it yourself and zip the content to send him the application.

Or Have you tried to right click then open the URL ?

Have you tried this

share|improve this answer
    
Opening the URL via the file menu results in the exact same error message. Like I stated, they cannot use anything else. I suppose they have WMP embedded in another application somehow. –  Wim Deblauwe Jun 17 '13 at 6:49

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.