Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a setup with a Cisco RV042 router connected as follows:

Broadband Motorola Surfboard -> Cisco RV042 -> Wirless Router
 |                                              |
 |-> Wirless N network                          |-> Wireless G network
      |                                              |
      |-> Home server w/ shared printer              |-> [Other PCs]

The Surfboard has a wireless N network, though the other wireless router runs on G for compatibility reasons.

The problem I am having is that I have a printer connected to a Windows computer on the wireless N router (with a static IP address), and I need computers on the G network to be able to use the shared printer. The printer is shared, though not through Homegroup.

On the other computers in the house (on the G network), I cannot see the server in the list of computers on the network, and I cannot seem to manually add the printer by typing in the IP address.

The question is-- how can I get other computers to detect the server connected to the printer, or what IP address/port/URL do I specify to connect to a shared printer on that PC?

share|improve this question
    
What are the DHCP, IP address, and subnet settings of each router? Do you have the G router's WAN port or LAN port connected to the N router's LAN port? –  rob Jun 15 '13 at 4:37
    
The DHCP for the G router is disabled, though both the Surfboard and Cisco RV042 have DHCP enabled. Everything has the same subnet mask (255.255.255.0), though the Surfboard hands out 192.168.0.x IP address, and the Cisco handles 192.168.1.x. I'll have to check which port is plugged in where. –  Andrew M Jun 15 '13 at 5:03

2 Answers 2

up vote 1 down vote accepted

Do you have both Routers handing out DHCP? Are both routers on the same IP subnet? If the surfboard handles DHCP, the G router has DHCP disabled (but is set with a static address on the same IP subnet... essentially just a bridge) then I can't see why all the computers shouldn't be able to see the shared printer.

For example... enter image description here

How does this grab you... make sense? Have the surfboard handle DHCP, and set the range to start at 50 or so. Set the G router to be a bridge, or at least disable DHCP, and connect it to the surfboard via one of the normal ethernet ports (not the Internet port). Assign it an IP that is outside the DHCP range, but on the same subnet (so you can easily get to it to adjust settings, etc). Then, all the computers that connect to the G router, will get an IP address that is in the same range that the server and printer are in. That should work.

share|improve this answer
    
Wow, thanks for the diagram! Currently, the actual wireless router (that's attached to the Cisco RV042) has DHCP disabled. The Cisco router (which is used for the dual-WAN capabilities) does have DHCP enabled with the same subnet mask, but assigns IP addresses that are 192.168.1.x (versus the Surfboard, which assigns DHCP 192.168.0.x). Would disabling the DHCP work in this case, and just let the Surfboard assign 192.168.0.[50+] IP addresses work? –  Andrew M Jun 15 '13 at 4:57
    
If I understand you correctly... you said the Surfboard modem has Wireles N capabilities... so you have the equivalent of three routers here? The Surfboard, a Cisco, and a Wireless G? If you have three routers, you only need to have ONE of them passing out IP addresses ( so turn off DHCP on the other two). Typically the one that is connected to the internet directly (the surfboard modem in this case) would be the one to handle DHCP –  Bon Gart Jun 15 '13 at 14:34
    
Yes, that is correct. The Wirless G router has DHCP disabled, though the Cisco and Surfboard have DHCP enabled and are assigning IP addresses on different subnets. This is because the Cisco has two modems connected to it-- one to broadband, and another to 4G WiMax from Clearwire (as a backup, since the broadband here is extremely unreliable). I have to check to see if the Clearwire modem can handle DHCP, or at least if I can disable DHCP for the primary WAN only. –  Andrew M Jun 15 '13 at 18:05
    
Well... you can have both the Surfboard and the Cisco use DHCP, just set their ranges to cover different spreads. Maybe set the Surfboard to use a range of 50 to 100, and the Cisco to hand out IP addresses on the same subnet, but from 100 to 150. –  Bon Gart Jun 15 '13 at 18:12

If you have both routers configured to use the same subnet, (e.g., 192.168.1.x/255.255.255.0), you need to configure the second router as a bridge or else the G router's subnet will mask the N router's subnet. Most consumer-level routers don't have a bridge option in their default firmware, although open-source firmware such as Tomato, OpenWRT, or DD-WRT most likely would allow you to configure bridging.

One easy solution is to disable DHCP on the G router and configure it with an IP address on the N router's subnet. Then instead of connecting the G router's WAN port to the N router, connect one of its LAN ports to the N router. This way, you're just using the G router as an access point. When a client connects to the G router, it will be assigned a DHCP address by the N router and will be able to see the server and its printer, assuming your sharing is properly configured.

Another solution is to simply set your routers to use different subnets (e.g., set the N router's subnet to 192.168.0.x and the G router's subnet to 192.168.1.x) and the computers on the G router should be able to see anything on the N router (but not vice-versa).

share|improve this answer
    
Interesting that you mention the different subnets-- that's how it's configured now. I should note that I can access that server directly by IP address (I have Plex Media Server installed and running), but it's the discovery that's not working. Alternatively, if I could figure out a way to add the IP address of the computer/printer manually, I wouldn't need the discovery, but the issue is finding the correct IP address or whatever to insert into the add printer dialog. –  Andrew M Jun 15 '13 at 5:05
    
Be sure to set the G router's DNS server to the N router's IP address. If the printer is connected directly to the computer via USB, you would use the computer's IP address. The printer only has its own separate IP address if it's plugged directly into the network. –  rob Jun 15 '13 at 5:13
    
Changing the DNS didn't seem to do much... The other computers on the network still can't seem to add the printer by its IP address and the server still doesn't show up in the Network list (nor does the printer get added successfully when I manually enter the computer's IP address)... Direct connection still works for Plex, so I'm guessing this has to do more with me setting up the printer incorrectly than the network configuration... –  Andrew M Jun 15 '13 at 5:39

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.